I can’t access form builder to edit current form.

  • Profile Image
    Erica 
    Asked on January 19, 2018 at 04:31 PM

    I’ve tried three different browsers, signing in and out of Weebly, and still no luck. It’s relatively urgent.  Thanks!

  • Profile Image
    Jed_C
    Answered on January 19, 2018 at 06:12 PM

    We apologize for the inconvenience.

    Jotform site and form loads fine from my end. Can you please try accessing your account / form again and let us know if you are still unable to. 

    Looking forward for your reply.

  • Profile Image
    JaySquires
    Answered on January 19, 2018 at 06:17 PM

    I'm sorry, but Jotform is the most difficult place to navigate I have ever seen! I commiserate with you Erica. I have been trying to find formbuilder for hours now so I can begin the process of integrating with MailChimp. When I click on the closest thing to it (My Forms) it simply tells me I have no forms. Aggggggggh! Please someone, help Erica and me.
  • Profile Image
    Jed_C
    Answered on January 19, 2018 at 07:25 PM

    @JaySquires,

    I have created a separate thread for you here www.jotform.com/answers/1355617. I'll be responding to your question shortly. Thanks.

  • Profile Image
    Erica 
    Answered on January 20, 2018 at 12:43 PM
    Hi,
    As you can see, my form is not loading on the public side of our site:
    [image: Inline image 1]
    Furthermore, I cannot edit the form on the back end.
    Thanks,
    Erica
    ...
  • Profile Image
    Mike_G
    Answered on January 20, 2018 at 05:07 PM

    @Erica

    We would like to apologize for any inconvenience, however, it seems that you have replied directly from the email sent to you when we responded to your question and the image that you are trying to show us didn't come through. To post a screenshot in our support forum, please follow the instruction in this guide — How-to-Post-Screenshots-to-Our-Support-Forum

    As for your concern, I have checked the page where your form is embedded and I was able to view it as it loaded without any issues — https://www.basketballkidschicago.com/form.html

    I also checked the form from your account and the form builder page (Edit Form) of the form is also loading just fine.

    Perhaps the issue no longer persist? Otherwise, please let us know.