Multiple issues with form functionality

  • Profile Image
    riskTVYMCA
    Asked on January 20, 2018 at 05:07 PM

    Hi,

    I'm having several issues with the functionality of my form.  These issues only seem to appear when connected to wifi on a tablet (i.e. ipad mini 2 and 4). The form works great on a variety of smart phones, my pc, and my macbook pro. Unfortunately, it is mandatory that the form works on a tablet.

    Here is what I've encountered:

    -The settings of a question asking the date of an event was set to "today's date".  Instead of changing daily, the date stuck on the date of the day the change was made.

    -User reaches the review and submit screen.  An item is selected to "edit".  The user changes the answer and then uses the green dots to advance to the end of the form.  This causes the form to crash.  Note: I tried having the user proceed through the form using the "next" button instead.  This resulted in the same problem.

    -User opens browser and views welcome page of form.  If "enter" is not selected within a few seconds, the form page turns white and freezes.  The form page is the homepage on Chrome and Safari.

    -User must select the "submit" button twice in order to provoke submission.

    -User submits the form.  Suddenly thereafter the form returns to the very last question (i.e. Upload Supporting Documents) before the thank you page appears.

    I've tried clearing browser data cache and form data cache, turning off restrictions, reducing the number of conditions, eliminating required conditions on hidden/conditional questions, updating widgets, and more. 

    I look forward to your assistance. 

    Thank you,

    Kim


  • Profile Image
    BJoanna
    Answered on January 21, 2018 at 02:52 AM

    You already reported an issue with the same form on this thread - https://www.jotform.com/answers/1345464 

    I tested your form again using the iPad emulator and I was not able to replicate the issues you reported. One of my colleagues also tested your form and the form is working on his end as well. 

    The issue could maybe be related to an iOS update. Was there a recent update on the device that you are using? 

    Considering that the issues you reported on this thread and the issue that you reported on your other thread are all related only to iPad mini 2 and 4, and considering that we (support team) cannot replicate the issue, we should wait to a reply from our developers on your other thread. 

    Also, did you check a reply from my college Elton on the other thread? Did you test the form using some other network?

    For now, until the issue is resolved by our developers, I can only suggest you to change the layout of your form to 'All Questions in One Page' and test the form using that layout. You can change the form Layout on the Settings page of your form.   

    1516520878legacy layout.JPG

    You can clone the original form and change the layout on the cloned form. 

    How to Clone an Existing Form from Your Account