Captcha and reCaptcha failling (not validated) and making a two-step form instead of just one

  • Profile Image
    hgc2002
    Asked on October 04, 2012 at 12:50 AM

     

    Following support instructions, I open this issue separately of the original comment, so we can try to focus on this matter at this time.

     

    Original question:

    .- Using recaptcha (or the simple form of it included in JotForm) simply does not work because it does not get validated before submiting the form.

    .- Well, that is not 100% true. After submiting the form there is a last step where another recaptcha is shown (I don't know if this is general for all the forms) but, again, it is in English and I cannot translate it.

     

    Additional information for resolution:

    Ok, here is the link to my form. There is not much I can set in the captcha properties. Currently I have it on the simple form, but using reCaptcha has the same behavior. Can you tell me what's wrong? I really hope this works.

     

    http://form.jotformeu.com/form/22753793138360

     

    Best regards,

     

    Herman.

  • Profile Image
    Rodjit
    Answered on October 04, 2012 at 02:01 AM

    Hi Herman,

    Your form is working fine on my end, I've use Chrome, FF and IE with all latest versions.

    Please try to check if you have Javascript enable, guide here

    Also, please try to logout and clear your browsers cache.

    Hope this help and please let us know if the above solutions don't work.

    EDIT:

    I have cloned your form and made a test submissions, all are working fine, no next page which asked for captcha again and it get validated.

    Thanks

  • Profile Image
    hgc2002
    Answered on October 04, 2012 at 03:24 AM

    I'm not saying that the form is failing when displaying. It's failing in the next two steps:

    Fill it up (actually, you have to fill the captcha with something wrong like aaa), and then you'll be asked to fill the captcha alone again. This should not be the normal behavior.

    I'm using Chrome Version 22.0.1229.79 m and FireFox 15.0.1 and the result is the same in both.

    I have screenshots, but I can't upload them here. Please let me know how can I send them to you.

    Also we can do webex if you want to see it alive.

    Regards,

    Herman

  • Profile Image
    Rodjit
    Answered on October 04, 2012 at 05:03 AM

    Hi Herman,

    I'm sorry to misunderstand your question and yes, I am able to see the issue. I will now forward this to our next level support and send a ticket to our developer regarding on this. Our developers will update you once this issue get fixed.

    Thank you for your cooperation.

  • Profile Image
    hgc2002
    Answered on October 04, 2012 at 07:00 AM

    Thanks for your answer. This is a hurry. We were going to have the website alive today but we can't do it without the forms. I'm sorry about the pressure but we can't delay it 24 hours more or we will have to switch to something else. 

     

    Thanks for your comprehension and help.

     

    Regards,

    Herman

  • Profile Image
    Rodjit
    Answered on October 04, 2012 at 07:35 AM

    Hi Herman,

    You can still use your forms and proceed making your site live, I think that issue isn't that worse because they can still submit the data and you are able to received them. Lets just say that users won't let theirselves enter a wrong codes and if they fail despite being redirected to another page to enter the correct captcha, the data's are there and users as I say can still submit it.

    Thanks

  • Profile Image
    hgc2002
    Answered on October 04, 2012 at 08:27 AM

    Our main concern is that this behavior brokes the language translation because the second page is shown in English, while the rest is in Spanish, as it's requested.

    Appart of that, it brokes a little the usability and presentation of the web without really need it. We don't want this to happen.

     

    Regards,

    Herman

  • Profile Image
    jonathan
    Answered on October 04, 2012 at 09:31 AM

    @Herman,

    Hi, just to be clear, we want to inform you that this is the current behavior of the form when 'wrong' captcha value is provided initially. The form will open to a next blank page with only the captcha field as the only option to continue form submit.

    As previously mentioned, there was already a feature request ticket that addresses this issue. We can only wait for the time when this will be address by our dev team.

    For the meantime, as an added functionality, you can also add a hover text in your form's captcha field. Having the hover text of the field positioned to easily seen by the form user will help minimize, if not eliminate wrong captcha value input. You can do something similar to this image...

     

    Hope this also help.

    Thanks.

  • Profile Image
    hgc2002
    Answered on October 04, 2012 at 11:54 AM

    ok, I understand your idea, but I'll wait for the enhancement.

    In the meantime we have switched to another form builder

    I hope this issue get fixed soon so we can come back to JotForm.

    Thanks for your help.

    Regards,

    Herman.