Drop down menu wont show options in form preview

  • Profile Image
    capconnect
    Asked on January 23, 2018 at 04:49 PM

    Hi, despite the cell having options - these don't show or drop down when filling put form for th

    "Typical Investment size" question in form below

  • Profile Image
    Marvih
    Answered on January 23, 2018 at 05:56 PM

    I don't see any option on your "Typical Investment size" Dropdown field.

    1516748169665.png

    I have cleared your Form Cache for now, can you please check again and add the dropdown options .

  • Profile Image
    capconnect
    Answered on January 23, 2018 at 06:43 PM
    I have added several times but then it disappears. Will try again.
    ...
  • Profile Image
    capconnect
    Answered on January 23, 2018 at 06:43 PM
    Hi, have just re-added the options and tried the form again . It still won’t show the drop down function. See attached pictures. Are you able to reinsert and try?
    Thanks
    Funda
    ...
  • Profile Image
    John_Benson
    Answered on January 23, 2018 at 08:20 PM

    Hello Funda,

    I cloned your form to test it on my end. I can see that the drop-down field is blank. I added some options and it was successful. Please check the screen capture of my test:

    151675642935dd3.gif

    I cleared your form cache on our server. Please try to edit the dropdown field again. If the issue still persists, please contact us again.


  • Profile Image
    capconnect
    Answered on January 24, 2018 at 04:43 AM
    Hi John,
    This issue is still not resolved. I have deleted the field and re-created it by duplicating another field in the same form which does work.
    Have input options again. Screen shot below. Once I refresh screen, the options disappear again and aren’t saved.
    Can we please fix asap as my form has been delayed 24 hours now and must go out this morning.
    https://eu.jotform.com/build/73516953981367
    thanks
    Funda
    [cid:image003.jpg@01D394F2.B3B8DE30]
    ...
  • Profile Image
    Kevin_G
    Answered on January 24, 2018 at 09:30 AM

    I have been checking your form and it seems like you were able to add the options: 

    15168041570.png

    15168041801.png

    If the problem persists, please provide us the screenshots following this guide (images attached on email responses will not reach this threaed): https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum 


  • Profile Image
    capconnect
    Answered on January 24, 2018 at 09:43 AM
    What we had to do was take out <1M from the options and then it worked. It doesn’t like “<”sign it seems. Is there a way around this?
    ...
  • Profile Image
    Kevin_G
    Answered on January 24, 2018 at 10:55 AM

    I think this is because the wizard thinks it's HTML code, if you add the option like "<1M" all will be removed, but if you add it as "< 1M" with a space right after the sign then it will work, I think this validation has been implemented in order to avoid malicious code to be used on the builder. 

    I hope this helps. 

  • Profile Image
    capconnect
    Answered on January 24, 2018 at 11:43 AM
    I think that was the culprit. Have noted for future reference. Have no idea what a HTML code is much less be able to write one !
    Thanks
    Funda
    ...