Why sometimes a submission is not calculated ?

  • Profile Image
    lejohn05
    Asked on January 25, 2018 at 08:58 AM

    Hi, why sometimes a submission is not calculated ? l i have 70 submissions but 3 or 4 submissions don't perform the calculation ?

    Thanks for your help



    This is a re-post of a comment on How to Perform Form Calculation Using a Widget

  • Profile Image
    BDAVID
    Answered on January 25, 2018 at 10:24 AM

    Please let us know what the form in question is, also let us know the submissions where the calculation was not performed. We will be glad to take a look and try to reproduce the issue.

  • Profile Image
    lejohn05
    Answered on January 28, 2018 at 07:27 AM

    Hi, here is the submissions id : 3926260413329618774 and 3926583895321067585


    At the line : nombre de plat individuel commandé : i should have 5 and 7 instead of 0.

  • Profile Image
    BDAVID
    Answered on January 28, 2018 at 08:44 AM

    I have revised your calculations, and they all appear to be fine. I have also filled the form the same way as in one of your submissions(where no calculation was performed), and as you can see, it worked fine:

    1517146811thesame.gif

    So, it is hard to determine what caused the problem. What I would suggest you is to remove the default zero value from your calculation field:

    1517146962zero.png

    And clear your forms cache: https://www.jotform.com/help/229-How-to-Clear-Your-Form-Cache 

    Let us know if the issue persists.

  • Profile Image
    lejohn05
    Answered on January 28, 2018 at 11:30 AM

    Thank you for your help. 


    I will perform the zero value and let you know.


    Because my biggest concern is in the futur i will add the payment option so i need to fix theses bugs firts

  • Profile Image
    BDAVID
    Answered on January 28, 2018 at 11:38 AM

    Perfect, update us if there is any new case where calculations do not perform.

  • Profile Image
    lejohn05
    Answered on February 10, 2018 at 03:31 PM

    Hi, it seem to be resolve by remove the default zero in the calculation field.


    Thank you,

  • Profile Image
    BDAVID
    Answered on February 10, 2018 at 08:32 PM

    Glad to know that. Open a new thread if you need anything else. :-)