Form submission: Not working - need it ready by 9am CET

  • Profile Image
    Elisacolombo
    Asked on January 25, 2018 at 12:53 PM

    Hello


    i was about to send out a form to my team, but first made a test registration myself with 2 more colleagues of mine and at the moment of submission, we all get the same error (image attached)

    The form i am referring to is called "NDe Europe FY18 Mid Year Event Registration Form".

    Perhaps you can see if there's any limitation flagged or what is the issue?

    Hope i can received a solution by tomorrow morning, 9am CET as i need to send out this registration form asap.

    Thank you!

    Kind regards
    Elisa Colombo

  • Profile Image
    Richie_P
    Answered on January 25, 2018 at 02:41 PM

    I cloned your form for testing purposes and made my own submission. I successfully submitted the form and did not encounter an error.

    Make sure your firewall did not block submit.jotformeu.com or check your anti-virus if it blocked the site.

    Try clearing your form cache

    If you still cannot submit, may we have a test submission on your form, to see if we can submit it using your form url ?

    We will wait for your response.

  • Profile Image
    Elisacolombo
    Answered on January 25, 2018 at 03:04 PM

    Hi Richie

    i have cleared the cache like you suggested, and filled in the form now, from my home internet connection, and i get the same error.

    i have also tried to submit a response into a different form i have created in the past, and i get the same error. This might be the reason why i am not receiveing answers in other forms i have currently open and shared to receive feedback.

    can you please check if there's something off with my account?

    thanks!
    Elisa

  • Profile Image
    aubreybourke
    Answered on January 25, 2018 at 04:10 PM

    I checked your settings and everything looks good. I submitted your form and it went through just fine:

    1516914249Thank You - Chromium_013.png

    Please try it again.

    If it reoccurs its likely that its a connectivity problem (as my colleague suggested).

    You could test it by loading your form on a different network. For example on your mobile phones data network.

    That will tell you if the problem is specific to your computer/network.

  • Profile Image
    Elisacolombo
    Answered on January 25, 2018 at 04:23 PM

    Hi 

    interesting. I have received your submission and i can register from my mobile phone, although with my laptop i am now on the same network and earlier this afternoon, i was on my work network (so a different one). And back then, also 2 more colleagues had the same error on the same network.

    Don't know what to say. I will have more colleagues trying it tomorrow.

    Hopefully it will work.

    thanks

    Elisa

  • Profile Image
    aubreybourke
    Answered on January 25, 2018 at 04:30 PM

    OK 

    Please get straight back to us if you encounter any more problems.