When I submit my form, it says "Please wait". Please help.

  • Profile Image
    RealityOlympia
    Asked on January 25, 2018 at 02:23 PM

    Hello,

    I did exactly as you did, but when I hit submit, it just says "please wait" and never shows a Thanks page. Are my settings off, or hyperlinks or encryptions blocking something? We'd like this up and running asap. Thanks!!

    Sarah

    503-410-0585



    This is a re-post of a comment on How to Clone an Existing Form from a URL

  • Profile Image
    Sabbir
    Answered on January 25, 2018 at 03:26 PM

    Can you provide us your form url so we can check?

    Also, are you having this issue with your stand alone form or after embedding it into a website?

    If you have embedded your form to a website, please provide us the website link.

  • Profile Image
    RealityOlympia
    Answered on January 25, 2018 at 03:29 PM

    Stand alone form after I copied and pasted the link from publishing.

    https://realityolympia.com/announcements, and it is under the 'women's retreat' section.  I think there is another person also working on it...I accidentally submitted a new support request. 

  • Profile Image
    jonathan
    Answered on January 25, 2018 at 05:33 PM

    Can you please confirm first that this is the form https://www.jotform.com/form/80245394289162 with the issue.

    I test submitted the form but so far I could not reproduce the problem.


    I see the Thank You page after form submission.

    Let us know if issue persist.