Source Code required fields not working - can't use built-in iframe