Embedded form does not work when viewed in Firefox.

  • Profile Image
    sroyal
    Asked on February 02, 2018 at 05:46 PM

    What bothers me is why you can't open the page from the link above. It opens fine in Edge and Chrome. However, I didn't mention it before, but JotForm does not work at all in Firefox on my computer. The login button doesn't even work, which is why I'm using Edge for JotForm. Also, when I bring up the Submit an Article form in Firefox, the text shows, but the form itself doesn't show at all. 

  • Profile Image
    Jed_C
    Answered on February 02, 2018 at 05:59 PM

    Neither Chrome nor Firefox allows me to view the page on my end.

    Sample screenshots:

    Firefox:

    1517612145ff_view.png

    Chrome:

    1517612194chrome_view.png

    With regards to the login button, it's possible that there's a script conflict between your other JS library that disables the login function. You can try re-embedding the form with an iframe to avoid this conflict.

    Let us know how it goes.

  • Profile Image
    vepaaUSA
    Answered on February 07, 2018 at 02:10 PM

    I have a content-heavy form that is also experiencing problems in Firefox. It loads promptly across all other browsers, but takes 2-3 minutes to load specifically in Firefox.

    While researching this issue, I found multiple posts over the last several years, also expressing problems with JotForm in Firefox. What is JotForm doing to rectify this long-standing problem?


  • Profile Image
    Jed_C
    Answered on February 07, 2018 at 02:16 PM

    @vepaaUSA,

    I have created a separate form for you in this thread https://www.jotform.com/answers/1376517. We will respond to you on that thread.