Email notification: Displays incorrect data

  • Profile Image
    duqadmin
    Asked on February 08, 2018 at 01:41 PM

    I have two items that keep showing up even though I did not select or fill anything out for them.(see screenshot)

    I checked this a few times and even tried deleting the dropdown and adding a new one. Can you take a look at this? Thanks!

  • Profile Image
    Mike
    Answered on February 08, 2018 at 03:06 PM

    It appears to be caused by a modified email template.

    When you have a modified email template, the form updates are not being added to your custom template.

    You may consider adding a new email notification to have a correct format.

  • Profile Image
    duqadmin
    Answered on February 08, 2018 at 03:21 PM

    This doesn't make any sense to me... There are certain things that I want to add or remove, so that's why I remove the Data Class label and add my own so that my email notification doesn't have a list of Data Class items which are not identifiable.


  • Profile Image
    Mike
    Answered on February 08, 2018 at 03:48 PM

    Unfortunately, we cannot guarantee that the 'Hide Empty Fields' option will work properly on the email with a modified structure. However, if you add a new email, it should have a correct structure. It should be also safe to update the text in the question column.

    Another option is to update the Dropdown labels and then add a new email notification.

    For example, if you change the 'Data Class' to the 'Net Read - Data Class' you will be able to identify it in the email.

  • Profile Image
    duqadmin
    Answered on March 02, 2018 at 01:45 PM

    I just created a brand new email and re-named the field labels in the email, only. It was working on Friday as I tested all of the selections and my conditions were working CORRECTLY. Today I went in to test again and now they are not working correctly from the dropdown: Post Bacc. - Pre Med down.

    I didn't change a thing since last week. Why did this happen? Very frustrating!

  • Profile Image
    Mike
    Answered on March 02, 2018 at 02:14 PM

    Are you still experiencing that issue? When I clone and test your form, the email notifications seem to be fine.

  • Profile Image
    duqadmin
    Answered on March 02, 2018 at 02:19 PM

    Yes, if you select Post Bacc. - pre med or the items under it, the email report does not match which items were selected. I checked the field id's and they are correct. It makes no sense!

  • Profile Image
    Mike
    Answered on March 02, 2018 at 03:27 PM

    It looks like that some of the field {names} are placed in wrong rows. The {names} should be placed in their corresponding rows. Please check the source code of the email template.

    Thank you.

  • Profile Image
    duqadmin
    Answered on March 02, 2018 at 04:04 PM

    So, I edited the code to match everything... well, the labels are still incorrect for Post bacc and below. Thanks, anyway.

  • Profile Image
    Kevin_G
    Answered on March 02, 2018 at 05:30 PM

    Like my colleague explained above, the fields names seem to be wrongly placed, for example, the field corresponding to "COMSOL Multiphysics" should have this value "{dataClass171}" as per your form, but the email notification has the following: 

    15200297241.png

    I can see you're using a combination of text and drop down element, you may only use the drop down and set the label to be as you want, for example "COMSOL Multiphysics", this way you do not need to add the texts again through the email template. 


  • Profile Image
    duqadmin
    Answered on March 07, 2018 at 09:06 AM

    So I took your advice, re-structured the form and edited the notification in dreamweaver... however, now the notifications are not included anything past my email address! HELP!

    1520431557Screenshot-2018-3-7 Mail - zol

  • Profile Image
    BJoanna
    Answered on March 07, 2018 at 10:57 AM

    it seems that you deleted your form https://form.jotform.com/80366150393960.

    Please provide us an ID of the form on which you are currently working on. 

  • Profile Image
    duqadmin
    Answered on March 07, 2018 at 10:58 AM

    https://form.jotform.com/80633678093969

  • Profile Image
    Kevin_G
    Answered on March 07, 2018 at 12:32 PM

    I have tested your and it actually works as expected, all the filled fields are being included on the email notification and the empty fields are hidden. 

    Example, this is what I filled on the form: 

    15204438151.gif

    This is what I received on email: 

    15204438612.png

    Please note that the static text is not included on the email template, the set of fields shown based on the selection made on "School/Department *" are not required either so the user can leave them empty and they will not be included on the email. 

    I hope this info helps. 

  • Profile Image
    duqadmin
    Answered on March 07, 2018 at 12:43 PM

    Hi, it works up until you get to Law. Everything report up until "SharePoint, LAWDATA, LAWAPPS" then the other school/department selections do not show.

    Try Law and University Advancement as tests. It's difficult to explain this.


    Here is where it cuts off under law:

    1520444516Screenshot-2018-3-7 Mail - zol

    And University Advancement:

    1520444612Screenshot-2018-3-7 Mail - zol

  • Profile Image
    BDAVID
    Answered on March 07, 2018 at 02:06 PM

    Since you have many fields, I believe that this is causing the problem as they exceed the characters limit supported in an email notification, so the "hide" empty fields feature would not work correctly.

  • Profile Image
    duqadmin
    Answered on March 07, 2018 at 02:10 PM

    Is there any way that this can be fixed? Thanks.

  • Profile Image
    aubreybourke
    Answered on March 07, 2018 at 03:34 PM

    Its working fine for me on a clone.

    I deleted the notification and added it again. And made sure it hides empty fields.

    I did a submission and the email I got was correct.

    For example:

    1520454850gwbqr.png

  • Profile Image
    duqadmin
    Answered on March 07, 2018 at 03:37 PM

    Try University Advancement, it doesn't report. Apparently there is a character max on notifications.

  • Profile Image
    aubreybourke
    Answered on March 07, 2018 at 03:57 PM

    Yes, I see it now. Your right its not displaying the data. Strange.

    I think we can escalate it to Level 2 support. The developers might be able to shine some light on this issue.

    Please bear with us as this can take some time.