Why am I getting a second captcha prompt?

  • Profile Image
    Printrbot
    Asked on October 14, 2012 at 07:38 PM

    I keep getting a seond captcha screen even though I am entering the correct phrase. What is going on?

    http://form.jotform.us/form/22808094848161

  • Profile Image
    Deygus
    Answered on October 14, 2012 at 07:48 PM

    Hello, I've taken a look at your form and I am unable to find the source of the problem. I currently only see one captcha field. 

  • Profile Image
    Printrbot
    Answered on October 14, 2012 at 08:13 PM

    Correct, but as soon as you complete the form and click submit you will get a second captcha prompt.

  • Profile Image
    Rodjit
    Answered on October 14, 2012 at 08:21 PM

    Hi,

    It is happen when your browser Javascript is turn off. Turn your javascript ON to solved that issue from your end, http://www.btny.purdue.edu/enablejavascript.html.

    Thanks

  • Profile Image
    Printrbot
    Answered on October 14, 2012 at 08:38 PM

    This is not the issue as my javascript is enabled and I only have this double captcha issue on some forms.

     

     In fact, here is another that is having the same trouble... http://form.jotform.us/form/22808630924152

  • Profile Image
    idarktech
    Answered on October 14, 2012 at 09:38 PM

    @Printrbot,

    I have replicated the problem after testing your form. But, it's not happening on a cloned version of your form. I have no clue what might be the issue is, but my suggestion is to clone your form, re-apply the captcha field and see if that works. Here's a guide on how to clone your form: How to Clone an Existing Form

    Let us know if this solution works for you. Apologies for the inconveniences caused.

  • Profile Image
    Printrbot
    Answered on October 14, 2012 at 09:47 PM

    I will give that a try.  Thanks.

  • Profile Image
    idarktech
    Answered on October 14, 2012 at 09:54 PM

    Great! We appreciate that.

    Just inform us if the problem still persist so we can assist you further with this.

    Thanks!

  • Profile Image
    davidgoebelstate
    Answered on October 31, 2012 at 11:48 AM

    I am having the same issue and it appears to be related to the upload image field.  Whenever I attach a file to the form I get the second captcha.  However, when no file is attached the captch works as expected.  I also tried cloning the form, which did work.  However, this is not a good solution as it not only resets my hidden counter field to zero, but I also have zapier integrations in place and changing the form causes a major headache.  Please run this by your developer in the hopes that they can fix the issue inline instead of us having to clone forms.  Thanks.

    Here is a sample form with the problem...

    http://form.jotform.us/form/22985844445163

  • Profile Image
    Welvin
    Answered on October 31, 2012 at 12:28 PM

    @davidgoebestate,

    May we know if how you embed your form into your website, if in case you did? Your forms works fine on my end. Please also try to check your browser's Javascript if it's turn on (http://www.btny.purdue.edu/enablejavascript.html).

    Please try using our iframe embed method:

    http://www.jotform.com/help/148-How-to-get-your-Form-s-Iframe-Code

    I hope this helps. Thanks

  • Profile Image
    davidgoebelstate
    Answered on October 31, 2012 at 12:37 PM

    Javascript is on and I am getting the issue within the preview. 

     

  • Profile Image
    Welvin
    Answered on October 31, 2012 at 01:03 PM

    @davidgoebestate,

    I will now forward this to our developers for attention. But I/we cannot promise you a timeframe to when this issue be fixed.

    P.S: I have tested your form for the second time and I was able to get the second captcha field.

    Thank you very much.