Why I'm receiving form error on submitting?

  • Profile Image
    quizmeisters
    Asked on February 18, 2018 at 06:27 PM

    Hi! 

    One of our Jotforms is not working, and I can't figure out why - hopefully you can help!

    https://form.jotform.co/quizmeisters/hosts-EOS-report

    I was able to submit this form on my Mac (with form response received), but instead of the thank-you page, this showed up: 

    1518996082Screen Shot 2018-02-19 at 10.2


    The form won't load on my phone (iPhone 6, iOS 11.2.5), with this message coming up. Our internet is working fine, by the way:

    1518996300EOS phone error.png 

    This is very important to our business, so please help! If you need any other info, please ask!

    Cheers,

    Bella

  • Profile Image
    Nik_C
    Answered on February 19, 2018 at 02:38 AM

    I did a test submission in your form and it worked fine:

    1519025614screencast.gif

    So, if the issue persists, it could be related to the network. Since the test you did on a phone was from WiFi as well.

    Please check if the form is submitting properly from 4G for example (or some other network) and if it does, your issue might be related to your network's settings (DNS, Proxy).

    Let us know how it worked.

    Thank you!