Form disappearing in Squarespace

  • Profile Image
    accwebsupport
    Asked on February 21, 2018 at 12:39 PM

    Dear Support,

     

    I created forms through JotForm and embedded them inside my Squarespace. However, when I visit the website the form will initially disappear.

    The form is embedded with a "Menu", which acts like tabs so I can have four forms embedded in one page and allow the user to easily navigate through them. If you click a different tab then the form will load, the problem of disappearing only occurs on the initial loading of the page.

    What can I do to stop the the form from disappearing? The URL is: http://www.accprinters.com/get-a-quote/.

    I am embedding the form using:

     
     
    I know that the possibility of iframe exists with Squarespace, but the "Menu" (tabs) does not allow for using that option.
     
    Thank you,
     
    Parker
    ACC Printers
  • Profile Image
    Kiran
    Answered on February 21, 2018 at 02:04 PM

    I have checked the web page provided and see that the forms in each tab are being displayed at my end without any issue. Were you able to fix the issue? Could you check once again using a private or incognito window or a separate browser to see if that helps?


    Let us know if you need any further assistance. We will be happy to help.

  • Profile Image
    accwebsupport
    Answered on February 21, 2018 at 02:12 PM

    I have tried multiple computers on our network, it disappears for all of them while using Firefox. However, if I use incognito in Firefox then the problem does not occur. It also does not occur on Chrome regardless of incognito.


  • Profile Image
    aubreybourke
    Answered on February 21, 2018 at 03:15 PM

    I was able to reproduce the problem using MS Edge browser.

    1519243990tiic4.png

    How are you embedding the forms?

    For Squarespace please follow the instructions here:

    Adding-a-form-to-Squarespace

  • Profile Image
    accwebsupport
    Answered on February 24, 2018 at 01:41 PM

    I resolved the issue by using HTML tabs inserted inside a "Code Block", and not Squarespace tabs (which they call "Menu"). Thank you for your support.