missing fields and missing conditions

  • Profile Image
    floydpr
    Asked on February 22, 2018 at 11:37 AM

    I went into this form to modify the emails of some people who will receive an email based on which department they chose and found many missing fields: https://form.jotform.com/60776170962967

    I checked, and the ones that are labeled with a "missing field" are in the department list and at some point those conditions were working.

    I noticed the same problem on this form,but fixed all the issues yesterday: https://form.jotform.com/53205538505957

    Another issue with the second form is that numerous conditions to send an email to someone based on which department someone chose were missing. The name of the department was in the list, but the condition I once set up was now missing.

    Actually, I just looked at the second form conditions and several conditions that did NOT have missing fields yesterday now do.

    The only similarity with the two forms is that there are many conditions, but I don't think that should matter, correct? If there is a limit, why are ones in the middle of the list having issues and not, for example, the last ones I created?

    I have no idea when this happened, as I have not gone into the forms conditions for a while to update the emails.



  • Profile Image
    Richie_P
    Answered on February 22, 2018 at 12:36 PM

    You are correct, I don't think there is a limit for conditions.  If you think the form was modified, you can check it in the Revision History.

    And revert it back to its previous form.

    Let us know if the issue still remains, so we can check it further.

    Thank you.

  • Profile Image
    floydpr
    Answered on February 22, 2018 at 01:43 PM
    I checked the revision history and that even raises more concerns.
    I may have made 120 updates yesterday to the GreenLink wow form (the second one I mentioned earlier) by 4:54, but I certainly did not make 120 by 10:48 a.m. yesterday and then another 118 by 10:45 a.m..
    I have not touched that form for a while before that, but it says I made 111 updates on Feb. 16 and 110 updates on Feb. 14. Not possible.
    No one else that has access to Jotform edits this form than me.
    Also, all the updates have to do with conditions being modified or added.
    Regarding the first form, it says I made 88 updates yesterday. I did not even open that form yesterday to edit it.
    I just checked something as I was writing this response. There are 88 conditions on the first form (I just counted) and probably 120 ( although I have not counted) on the other one.
    Also, as I went through the first form just now there are SIGNIFICANTLY more missing fields than when I wrote the first message to you earlier today.
    It is almost as if something is automatically scanning every condition and modifying it, sometimes removing the first field of the condition.
    Yes, PLEASE investigate further.
    Mark Hannah
    Internal Communications Coordinator
    Public Relations
    706.509.3253 phone | 770.905.9172 cell
    mhannah@floyd.org| www.floyd.org
    Corporate Support Center
    420 E. 2nd Ave.
    Rome, GA 30161
    ...
  • Profile Image
    Richie_P
    Answered on February 22, 2018 at 02:46 PM

    Do note that, every little changes in the form, the revision history stores it.

    I cloned your form , and I can't seem to replicate the issue on condition and fields changing.

    It might be that, you changed a field and the condition affected is affecting all other conditions associated with that field. It created a domino effect for your conditions and the fields ,that's why it is registering  a lot of revisions for the day.

    May I suggest fixing the missing fields, and let us know if the issue still remains.

    Thank you.

  • Profile Image
    floydpr
    Answered on February 22, 2018 at 03:43 PM
    Maybe give it a day or two and see if anything changes on your cloned form.
    I actually fixed all the missing fields in one of the forms yesterday, only to see different ones appear today. I have no idea if any conditions were removed. I do need to fix them again, but not to test as much as to make sure people in the different departments get the email submissions.
    One thing about your suggestion. I did not even go in to edit either of those forms on the day it says I did. For example, the first one says I we in there yesterday and I did not even pull it up, much less go to edit it.
    Have you all ever had bots cause any issues or people’s accounts compromised in any way? I am thinking I probably need to change our password.
    Mark Hannah
    Internal Communications Coordinator
    Public Relations
    706.509.3253 phone | 770.905.9172 cell
    mhannah@floyd.org| www.floyd.org
    Corporate Support Center
    420 E. 2nd Ave.
    Rome, GA 30161
    ...
  • Profile Image
    floydpr
    Answered on February 22, 2018 at 04:43 PM
    I have replaced all the missing fields for both forms. I will keep an eye on it and let you know what happens.
    Mark Hannah
    Internal Communications Coordinator
    Public Relations
    706.509.3253 phone | 770.905.9172 cell
    mhannah@floyd.org| www.floyd.org
    Corporate Support Center
    420 E. 2nd Ave.
    Rome, GA 30161
    ...
  • Profile Image
    Richie_P
    Answered on February 22, 2018 at 04:48 PM

    Hopefully by correcting the missing fields, the issue would be fixed.

    We don't have bots and we assure you no account is compromised.

    Thank you.