Zoho CRM integration not working

  • Profile Image
    alityfun
    Asked on February 24, 2018 at 09:32 PM

    Hello JotForm support, hope you're having a great weekend, I'm using a Wordpress site and Zoho-CRM platform, notice that you offer integration for it, I've tried several times to log in using my username and pw with no success, so I've switched to auth token just to get the same results, is that an available feature still?? or is not working anymore, or the last option... what am I doing wrong?? please help 

    I also have a second request, in my autoresponder, I'm trying to include a pdf document for my prospects (it's an application) but is not uploading correctly, it says when I receive the email in a test email that the attachment is corrupt, thanks in advance for your help.
    :-)
  • Profile Image
    alityfun
    Answered on February 24, 2018 at 10:27 PM

    I've got the integration working, thanks, it's just the attachment now please :-)

  • Profile Image
    John_Benson
    Answered on February 25, 2018 at 03:44 AM

    I tested your form and I was able to replicate the issue. The PDF attachment cannot be opened. Please try to re-upload the PDF again by following the screen animation below:

    151954785977466j.gif

    Also, please make sure that the PDF is uploaded properly. I checked the PDF size and it is 1KB. Is that correct?

    15195481333547b4.png



  • Profile Image
    alityfun
    Answered on February 25, 2018 at 11:37 AM

    Thanks for your response, I did upload the document that way and still didn't worked, then I dragged and dropped the file to upload and is working now. 

    Coming back to the integration feature, I was able to log in and make the adjustments for the ZOHO-CRM, however, is not transferring any data at all to my CRM platform.

  • Profile Image
    Kiran
    Answered on February 25, 2018 at 12:54 PM

    I did upload the document that way and still didn't worked, then I dragged and dropped the file to upload and is working now. 

    The issue might be happening due to the file name of the attached file. Please try removing the attached file and rename the file to attach it again. 

    I was able to log in and make the adjustments for the ZOHO-CRM, however, is not transferring any data at all to my CRM platform.

    I see that the Zoho CRM is connected to your JotForm and the fields seem to be mapped correctly. I have sent a test submission to the form. Could you check if the submission is passed to Zoho CRM.

    Let us know if the issue still persists. We will be happy to help.

  • Profile Image
    alityfun
    Answered on February 25, 2018 at 03:28 PM

    Hi Kiran, thanks for your help, I've checked the CRM and is not passing the information at all

  • Profile Image
    jonathan
    Answered on February 25, 2018 at 04:44 PM

    I checked your form and I can see the Zoho CRM integration was correctly setup and authenticated in the form.

    1519594165zzz 2018-02-26 05.27.09.png


    ...I've checked the CRM and is not passing the information at all

    It is possible also you were just not seeing the data in Zoho due to the View option in Zoho lists.

    https://help.zoho.com/portal/community/topic/change-view-in-open-leads

    Can you please check also in the viewer tab and be sure the "All Open Leads" option is the selected option.

    Let us know if this still did not resolve the issue.



  • Profile Image
    alityfun
    Answered on February 27, 2018 at 02:15 PM

    Hello and thanks again for troubleshooting my case, I did check and yes, the "All Leads" is the tab view that I'm on, still does not let me see any new test lead so far.

  • Profile Image
    Kiran
    Answered on February 27, 2018 at 02:40 PM

    Could you try generating a new auth token in Zoho CRM to integrate with JotForm to see if that works?

    https://www.zoho.com/creator/help/api/prerequisites/generate-auth-token.html

    Also, please let us know if you have any custom fields setup in your Zoho CRM. 

    Thank you!

  • Profile Image
    Kiran
    Answered on February 27, 2018 at 02:40 PM

    Could you try generating a new auth token in Zoho CRM to integrate with JotForm to see if that works?

    https://www.zoho.com/creator/help/api/prerequisites/generate-auth-token.html

    Also, please let us know if you have any custom fields setup in your Zoho CRM. 

    Thank you!