Conditional Logic/Old Layout: Copying value from one drop down to another does not work with certain string.

  • Profile Image
    losdbenefits
    Asked on February 28, 2018 at 06:15 PM

    Hi,


    I'm trying to have the form auto fill based on the radio button selection, "Yes, I'd like the same plans as I chose for 17-18

    If this yes button is chosen, I'd like the text from 17-18 Medical to appear in 18-19 Medical.  So far, when I click yes, it does not populate that 18-19 field for me.  I've created a condition as follows:


    if Radio field

    State: is equal to

    Value: yes, I'd like the same plans as I chose for 17-18

    DO copy a Field's value

    From 17-18 Medical Plan A

    To 18-19 Medical Plan A


    Doesn't seem to be working though...



  • Profile Image
    Kevin_G
    Answered on February 28, 2018 at 09:25 PM

    Apologies for the inconveniences this may have caused to you, I have been testing this and I was able to replicate the issue, for some reason it does not work with the options you have on your current drop down, if I add different options it works, example: https://form.jotform.com/80588095070966 

    I have been spending some time testing this, but I could not find a way to resolve it, I will forward this to our second level so our developers can have a look on this, we will keep you updated via this thread. 

  • Profile Image
    losdbenefits
    Answered on March 01, 2018 at 11:07 AM

    your example doesn't use the radio button...did you try it that way as well?

  • Profile Image
    Kevin_G
    Answered on March 01, 2018 at 11:39 AM

    Yes, I tried it on the cloned form and where I initially replicated the issue, actually it does not matter if there is a radio button or not, the problem actually has to do with the conditions and the certain strings on your drop down, basically the conditions on my sample form are behaving the same. 

    As I stated on my previous response, this issue has been forwarded to our second level, our developers will further investigate and resolve this, we will keep you updated here.

    Thanks. 

  • Profile Image
    janberk
    Answered on March 02, 2018 at 09:31 AM

    This issue should be fixed now. If you have further issues please let us know.

  • Profile Image
    losdbenefits
    Answered on March 02, 2018 at 05:21 PM

    Works now, thank you very much!