Active form tabs is not displayed correctly in embedded form.

  • Profile Image
    martijnsiegers
    Asked on March 01, 2018 at 02:52 AM

    Hello,

    I am building a configurator with Jotform. Have been doing this for a while now and it works great. But I ran into one problem with the tabs widget. I have been looking at the forums to solve this problem but cannot find a solution.

    I have changed the widget to mywebsite style and all is working fine when I go to the form directly:

    https://form.jotformeu.com/80471667148362

    But I have used the Jotform Wordpress plugin to get the form into our website and somehow the tabs widget starts to have a bug.

    https://mycampster.nl/configurator/

    When you go to the second page the tab stays on the first page. And from there on it works again but is always one page behind....

    I have tested it on several computers and phones, all with the same problem. This is the same for other configurators that I use.

    Do you have a solution? Hope you can help.

    Kind regards,

    Martijn Siegers

  • Profile Image
    ashwin_d
    Answered on March 01, 2018 at 06:42 AM

    I did test your form which you have embedded in your webpage and I am able to replicate the issue you are having. The active form tabs is not being displayed correctly. When I tested your form using its direct URL, the form tabs widget is displayed correctly when we move between different pages.

    I would suggest you to please embed your form using its iFrame embed code and see if that solves your problem. The following guide should help you how to grab your form's iFrame embed code:  https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    Hope this helps.

    Do get back to us if the issue persists.