Cards: Question # on dot hover is incorrect

  • Profile Image
    SteritechQA
    Asked on March 01, 2018 at 06:56 AM

    The progress bar does not display the field title for text fields correctly in the progress bar.  When you however the mouse over one of the dots it will display the question/field title however for text fields it will display the text "Question #" where # is the index of the question in you form layout during editing.

    This is annoying because, as you can see in the screen shot below, the 6th field displayed is given the title "Question 27" but in fact has a very different title.  It is given the "Question 27" title because it is the 27th field on my form when editing the form (it is the 6th field displayed at runtime due to conditional logic).  Worse yet, the total number of fields being displayed is 15.  How can a form with 15 fields have a "Question 27"?

    Please correct this issue of text field titles not being displayed correctly in the progress bar and please also give priority to the feature request to add an option to remove the progress bar from the cards layout.

  • Profile Image
    Adrian
    Answered on March 01, 2018 at 09:19 AM

    Thank you for this report.

    I will forward this to our developers and we will let you know via this thread when there is an update.

  • Profile Image
    SteritechQA
    Answered on March 01, 2018 at 09:49 AM

    Thank you.

  • Profile Image
    kaan
    Answered on March 02, 2018 at 10:40 AM

    Hello SteritechQA,

    This issue should be fixed now and progress bar now should properly display associated labels when there is no question text. Can you please check it and confirm that it is working as expected now?

    Thank you, have a great day!