The form embedded on our website is stuck on "Please wait" when being submitted

  • Profile Image
    Asked on March 01, 2018 at 10:57 AM

    Hi guys, our company use the credit application form in our website We already received complains of clients that after they completed the credit application form they click the submit button and the botton says "please wait", after that nothing else happens, just stay that way. We already tried with Google Chrome and Mozilla Firefox.

  • Profile Image
    Answered on March 01, 2018 at 12:16 PM

    We would like to apologize for any inconvenience the issue is causing you. I can confirm the issue you described after I tried submitting your form. However, I wasn't able to reproduce the issue when I made a test submission on a clone version of it using the direct form URL. In that case, the issue could be on how the form was embedded on the website. May I suggest that you try embedding the form to your website by following this guide — A-Guide-to-Embed-Forms-for-WordPress-Users?

    If that would not still fix the issue, please let us know.

    On another note, I have noticed that your form collects Social Security Number and Driver's License Number which falls under Phishing and Collecting Sensitive Information of our Terms of use. May we suggest that you use our Encrypted Form feature and add a form signature widget to your form since you are collecting these types of information, please?