Why are people able to skip a required Jotform field and still send the form?

  • Profile Image
    beachandforestrealty
    Asked on October 19, 2012 at 12:48 PM

    I am receiving many emails without all the required fields filled in. This is costing me money for leads that are not complete. What can I do about this? Is it they are not entering it or is it that Jotform is not recording it. How can we fix this.

    This form is in the account of beachandforestrealty and located at the attached url.

  • Profile Image
    Rodjit
    Answered on October 19, 2012 at 01:14 PM

    Hi,

    We are sorry about this, this usually happen when browsers Javacript is disabled or broken, hence you can bypass Form's Required Fields. I can see that your recent submissions has been filled in and those blank are from the past days, so I am hoping that this issue won't happen again.

    Let us know if the problem still persist from now on so we can forward/ask our developes about this certain issue.

    Again, we are sorry about this.

    Thanks


  • Profile Image
    beachandforestrealty
    Answered on October 19, 2012 at 01:19 PM
    Please monitor this issue for any future problems...this is a very costly problem for our company..thaNK YOU
    David Levy
    Beach & Forest Realty
    Broker / Owner
    Cell (843)446-3412
    Office (843)712-2721
    Fax (843)712-2723
    Email: DLevyhomes@aol.com
    Website: www.BeachandForestRealty.com



  • Profile Image
    Rodjit
    Answered on October 19, 2012 at 01:29 PM

    Hi David,

    We will. I will try to forward this to our developers and see if what their thoughts about this certain issue.

    Thanks

  • Profile Image
    jeanettebmz
    Answered on October 19, 2012 at 02:22 PM

    @beachandforestrealty

    This issue might be corrected by embedding the form using the iFrame code instead of the javascript one,  as it will prevent other js code to interfere with form's code.

    Please give it a try or let us know if you need further assistance

  • Profile Image
    aytekin
    Answered on October 22, 2012 at 08:45 AM

    I agree with Jeanette. Please use the IFrame code. It is probably happening because of a JavaScript conflict in your page. (And, this is exactly why when there is a javascript problem on your page we let the data come to you. Otherwise, people wouldn't able to submit the form and you wouldn't even be aware of the problem.)

    Here is how you can get the IFrame code. Open your form on the Form Builder:

    1. Open "Setup & Embed" tab on toolbar,

    2. Click on "Embed Form"

    3. Click on "iFrame".

    I hope this helps. Please let us know how it turns out.