Why widgets section is not loading in the form builder?

  • Profile Image
    cowryasset
    Asked on March 06, 2018 at 08:50 AM

    Good day,

    I keep getting the error stated below on my form. I have refreshed severally but it still persists. Kindly help resolve.

    Error : Oops! Something went wrong and We couldn't initialize widget list.


    Thank you

  • Profile Image
    BJoanna
    Answered on March 06, 2018 at 10:09 AM

    I inspected your form but I did not saw any error message. Your form also does not have any widget. All fields inside of your form are basic fields. 

    Did you remove the widgets from the form?

    Or is the error message shown when you add a widget to your form? If so, please let us know which widget are you unable to add to your form and provide us a screenshot of the error message. 

  • Profile Image
    cowryasset
    Answered on March 06, 2018 at 10:45 AM

    1520351162widget_list_not_loading.JPG

    I have not added widgets to the form because of the error.

    It comes up on the landing page after clicking on "Edit Form". And when I try to add a widget, no list is populated

  • Profile Image
    Kevin_G
    Answered on March 06, 2018 at 12:16 PM

    Apologies for the inconveniences  this may have caused to you. 

    I have been testing this and I can see the widgets are loading properly and the error does not appear on my end: 

    15203564231.png

    I think this might be related to something in the browser or network, I would recommend you to try using a different browser, computer or internet connection, please also make sure that your browser or computer do not have any security software that may be blocking resources. 

    Please let us know how it goes. 

  • Profile Image
    cowryasset
    Answered on March 08, 2018 at 03:24 AM

    I enabled developers tool on my browser(chrome) and I got the error below.

    "Failed to load https://apps.jotform.com/apps/widgetlist/?username=cowryasset:

     No 'Access-Control-Allow-Origin' header is present on the requested resource. 

    Origin 'https://www.jotform.com' is therefore not allowed access. 

    The response had HTTP status code 403"

    1520497391Access-Control-Allow-Origin_Er

  • Profile Image
    Nik_C
    Answered on March 08, 2018 at 06:17 AM

    I cleared your forms cache, please try now. If the issue persists, please try clearing the browser's cache and see if the issue persists.

    Thank you!