Embedded form: Full source method - not submitting

  • Profile Image
    floydpr
    Asked on March 06, 2018 at 10:31 AM

    I have embedded the following form onto a page using the source code: https://form.jotform.com/72196647516970

     

    However, when someone tries to submit it, it just keeps showing a blank version of the form and the submission does not go through. 

    Usually in our CMS we use a web part called a Script Editor and we drop in the iframe Code. But for this one it keeps disappearing when we check in or publish the page. The embed code does not work at all. therefore, the only option we have is the source code. 

    We have to use Internet Explorer and most of the organization is on IE 11. 

  • Profile Image
    aubreybourke
    Answered on March 06, 2018 at 11:48 AM

    OK, I was able to submit using the direct link to your form.

    1520354755n2vsn.png

    The issue is most certainly your CMS solution. Can you tell us which one you are using? Its possible that we have a specific embed method that could work.

    Failing that you would best contact support for your CMS solution. And ask them how do you embed HTML in it.

  • Profile Image
    floydpr
    Answered on March 06, 2018 at 02:43 PM
    After I sent you the message I tried it as its own link and not embedded and it worked fine, as you demonstrated below. So, I do agree it is a CMS issue. I just made a link from some text on the page.
    We use a company called CoDesigned and they are actually using the SharePoint platform, but there are some quirky things that specifically happen with our site.
    The odd thing is I have embedded iFrame code for forms on at least 12 pages and they are not showing any issues. There may be reasons that this one is giving us an issue, and it is definitely related to our CMS vendor.
    Thanks for your help.
    Mark Hannah
    Internal Communications Coordinator
    Public Relations
    706.509.3253 phone | 770.905.9172 cell
    mhannah@floyd.org| www.floyd.org
    Corporate Support Center
    420 E. 2nd Ave.
    Rome, GA 30161
    ...
  • Profile Image
    aubreybourke
    Answered on March 06, 2018 at 02:47 PM

    OK, you use SharePoint. That's good because we support it.

    Please see this guide:

    Adding-a-form-to-SharePoint

  • Profile Image
    floydpr
    Answered on March 07, 2018 at 09:43 AM
    These are interesting instructions, because we contain some of this functionality, but the process we use is actually very different. I will try this and see if it functions any better.
    Mark Hannah
    Internal Communications Coordinator
    Public Relations
    706.509.3253 phone | 770.905.9172 cell
    mhannah@floyd.org| www.floyd.org
    Corporate Support Center
    420 E. 2nd Ave.
    Rome, GA 30161
    ...