Why can't my respondents submit the form on mobile?

  • Profile Image
    AlphasTeamRep
    Asked on March 08, 2018 at 11:03 AM

    Hi,


    I've looked on the forum but cannot find this issue or a solution. I've created this survey which is being sent via email. It seems to work fine on desktop and also on the Mobile view when previewing the form.

    Reports from users and also testing myself (Users on iPhone, myself on Android (Sony Xperia z5) show that submitting answers to questions works fine but when attempting to submit the 'submit' button flashes 'Please wait..' then returns to 'submit' and I do not receive a response. 

    I have had a paltry number of responses as I have had to ask people to fill out the form on desktop. Is there something I'm missing or could be changed to allow? Please help!

    Thank you in advance,

    Jamie

  • Profile Image
    Kiran
    Answered on March 08, 2018 at 11:44 AM

    I have tried submitting your JotForm on Sony Z5 mobile emulator and was able to submit without any issue.

    1520527039bs_realdroid_Mobile_Sony Xperi

    Could you let us know if the issue happening when the user is trying to make a change to an earlier selected field? This might be happening due to the option Clear hidden field values. When the user tries to change the option, the option for the already selected field will not be cleared. Please try changing the option to Clear on being hidden so that it should be working fine.

    1520527293ClearonBeingHiddenV4.png

    Let us know if you need any further assistance. We will be happy to help.

  • Profile Image
    AlphasTeamRep
    Answered on March 08, 2018 at 12:08 PM

     This option seems to have fixed it on my device. I will send it out again and see how the recipients get on.

    Thank you for your help so far :)