Card Forms: Show/hide conditions based on payment field are not working.

  • Profile Image
    terisman
    Asked on March 13, 2018 at 03:31 PM

    Hi, 

    I built my first form using JotForm cards. It works fine on desktops/laptops. However, some problems are happening when viewed by mobile device:

    The show field condition is not working on mobile. If shipping is selected as a product and added to the cart, the shipping address field should display. That field is being skipping when viewed on a phone.

    1520969339Screenshot_20180313-1409152.pn

    (1) In screenshot above: can the blank area at the top of the form be reduced on mobile devices? This forces users to scroll down to see all my products.

    (2) In screenshot above: on mobile devices, some sizes are not available for my products for sale. "Small" size is missing from both men's and women's jacket options.

    Thanks,
    Terry E.

  • Profile Image
    Kevin_G
    Answered on March 13, 2018 at 04:38 PM

    I have been testing the conditions you have configured on your form and they do not work on desktop either. 

    I will forward this thread to our second level and we will keep you updated via this thread. 

    Regarding your other questions, as they are related to different matters, I have moved it to different threads in order to assist you better, we will assist you as soon as possible here: 

    https://www.jotform.com/answers/1414022

    https://www.jotform.com/answers/1414021 

    Thanks. 

  • Profile Image
    terisman
    Answered on March 13, 2018 at 04:58 PM

    Thank you!

  • Profile Image
    can
    Answered on March 14, 2018 at 10:22 AM

    Hi Terisman,

    We have fixed your problem. Shipping address will be shown if the shipping product is selected.

    If you need any further assistance, please let us know.

    Regards.

  • Profile Image
    terisman
    Answered on March 14, 2018 at 03:29 PM

    Hi, the problem has been resolved and I see the shipping option via mobile device now. 

    What caused this -- was it something I had not done properly on the form builder?

  • Profile Image
    BDAVID
    Answered on March 14, 2018 at 04:24 PM

    This appears to be something that our developers had to fix, but not because you missed something, or did something not properly.

    Open a new thread if you need anything else, we will be glad to assist you.