Form: The form just disappears when users are almost finished it

  • Profile Image
    Miriam85044
    Asked on March 13, 2018 at 09:58 PM

    My Gallery portfolio submission form seems to work and then at the very end after the users have clicked that they are human, it just disappears!  This is not good.  Is the form input not being saved in the background?  How can they retrieve everything they've done to do that point without starting all over??


  • Profile Image
    gizem
    Answered on March 14, 2018 at 06:16 AM

    I have cloned your form and tested it. I did not encounter any problems while submitting the form.

    See the screencast below:

    15210221211.gif

    As far as I see, your conditions are not conflicting and working as expected.

    Could you ask your users on which step they are stucking? Are they seeing any errors in the console?

    You can follow this guide to see the errors on the console of the browser.

    Also, I have cleared your form caches. If the issue still persists on your end, please clarify the steps. So, we can check the problem further.

  • Profile Image
    Miriam85044
    Answered on March 14, 2018 at 12:43 PM
    Hello,
    Thank you so much for the reply. Unfortunately, 2 out of 3 users have indicated this happening. There is apparently no error code or notice – it just “disappears”. It seems to be occurring right after they click the “I am not a robot” and before they get a chance to “submit”.
    And the real issue here is that they have spent hours working on their submission, meanwhile the form and it’s inputs are not being saved anywhere in case of a crash/technical issue… This is not good as you can imagine. Is there a way to remedy that at a minimum for longer forms?
    ~Miriam
    ...
  • Profile Image
    Richie_P
    Answered on March 14, 2018 at 01:24 PM

    I checked your form and you have already enabled the Continue forms later. This would let your user's inputs be saved and the users can continue filling up their forms after closing the form.

    I have tested your form and I can't seem to replicate the issue.

    Make sure your users are not blocking the Captcha widget with their Internet security .

    Let us know if the issue still remains, so we can check it our further.

  • Profile Image
    Miriam85044
    Answered on March 14, 2018 at 01:43 PM
    Okay, well that’s good to know. And I imagine it may very well be a pop-up blocker issue as you suggest – possibly. I have shared this with our users. Thank you.
    ...
  • Profile Image
    jonathan
    Answered on March 14, 2018 at 02:06 PM

    If you have published the form on your website, we can also do further test if you can share to us the URL of the website where the form was used.

    I assumed for now all is good already. Please contact us again anytime should issue persist.

    Regards

  • Profile Image
    Miriam85044
    Answered on March 16, 2018 at 11:43 AM
    Hello,
    I am really frustrated. Almost every single person who’s been submitting portfolios has said that they’ve had issues. 1. The screen and data just disappearing at the very end before getting to hit the submit button, and 2. The file uploads have been a serious pain and people are giving up.
    Not happy with this. What’s going on?
    http://www.az-artisanscollective.com/ggrfp.html
    Portfolio Submission form – in step #2.
    The other form in step #1 has apparently been having some issues with the image upload as well.

    Please advise.
    ~Miriam
    ...
  • Profile Image
    gizem
    Answered on March 16, 2018 at 01:30 PM

    I did test submission to your 'Grotto Gallery Portfolio Submission' form as you can see in the below screencast:

    15212204181.gif

    I did not encounter any problems when I submitted your form. Could you please ask people who encounter the problem that which device and browser are they using?

    So, we can check the problem further.

    I have split your second question to a new thread to prevent the confusion. You can follow it here: https://www.jotform.com/answers/1417592 

  • Profile Image
    Miriam85044
    Answered on March 27, 2018 at 04:43 PM
    This CONTINUES to happen (see email below) with multiple forms. There is ZERO error message. I am running a business. And currently I feel that without further resolution on this I may need to cancel my subscription and find another, more reliable forms solution. I have asked to speak with someone to get this resolved as there has been no progress. You have a major issue with your forms and NOBODY there is doing anything concrete to resolve it. I am incredibly frustrated and previously was a very happy customer. Not good!!
    ~Miriam Carlson-Maier
    ...
  • Profile Image
    Welvin
    Answered on March 27, 2018 at 06:17 PM

    Please accept our sincere apologies for the inconvenience. We understand how frustrating this may be considering the length of the form.

    You've mentioned the problem might be related to the re-captcha section at the end of the form. In this case, I would suggest removing that captcha to troubleshoot and see if that's really causing the issue. We already have an anti-spam measure in place, so nothing to worry about getting spam submissions.

    If you need a captcha, you can enable the captcha option in the Form Settings. But please do this once you confirm the captcha field is causing the problem. 

    Show Captcha on Submitting Form


    I'm so sorry again because we do not have a phone support. We are only available through this forum, occasional chat and support email. For urgent matters, we recommend this support forum as we are here 24/7 with an average response time of 2 hours (today's ART).

    I hope that works. Please keep us updated. 

  • Profile Image
    Miriam85044
    Answered on March 27, 2018 at 07:43 PM
    You know – I’m never going to know what is causing the problem – I don’t have any reason to suspect it’s the captcha function or not. I’m not a programmer or developer. I’m a business owner who is paying for a service from your company – and it’s not working!
    ...
  • Profile Image
    Kiran
    Answered on March 28, 2018 at 01:50 AM

    We are sorry for the inconvenience being caused. I have also tried submitting your form on a chrome browser with Windows 10 and was able to submit without any issue. Since, we are not able to replicate the issue at our end could you check with your users if the issue occurs on any specific browser, OS or a device? This would help us in replicating the issue at our end and assist you accordingly.

    Thanks!


  • Profile Image
    Miriam85044
    Answered on March 29, 2018 at 12:43 PM
    I have answered that specific question AT LEAST once. I have two different issues running with you guys – although they are with the very same forms.
    This is ridiculous.
    You can’t replicate an issue that is occurring with many different customers of mine on many different browsers/devices? Now what??
    ...
  • Profile Image
    Kiran
    Answered on March 29, 2018 at 01:10 PM

    I have tried again submitting the form using Firefox browser and was able to submit without any issue. It would be helpful for us if you can get any screenshot or any console error message displayed on the browser from your users to provide you with the appropriate solution. Could you check with your users if they can provide us with the information?

    We will wait for your response. Thank you! 



  • Profile Image
    Miriam85044
    Answered on March 30, 2018 at 05:43 PM
    Well – I assume that since the form just disappears there is no error message. And… besides, I’ve already asked and passed on all the feedback I was given by 3 or 4 users who had issues.
    ...
  • Profile Image
    jonathan
    Answered on March 30, 2018 at 08:00 PM

    I have also test and reviewed your form https://www.jotform.us/form/80537343147153  but I also did not encounter any problem using the form so far.

    1522453975zzz 2018-03-31 07.49.57.png

    I enabled the browser console to be able to see the back-end script processes working, and it also shows that everything were working properly.

    We are being limited on which direction to further troubleshoot if your form have issue since we haven't been able to reproduce the issue you have reported.

    ---

    Well – I assume that since the form just disappears there is no error message...


    After form submission, the Thank You page/screen will be shown. 

    1522454391zzz 2018-03-31 07.58.11.png

    Are you saying the Thank You page did not show after you submitted the form? Can you please clarify this.


    Let us know if issue persist.

  • Profile Image
    Miriam85044
    Answered on March 30, 2018 at 08:43 PM
    Right – it disappears. That means it crashes and nothing gets submitted to your system.
    Also – I am not the user – my customers are. I am only getting complaints and losing business – not sitting over their shoulders or getting a play by play as to what did or did not happen in minute detail. The reason they are annoyed is because they’ve filled the form and then it disappears before they can submit it – no way to recover, no record of it, they’ve waisted their time. No error message. No thank you screen – because NO FORM IS SUBMITTED – it just disappears.
    You have a problem. It needs to be fixed. Else I can go to another forms application that does not crash.
    ...
  • Profile Image
    Kiran
    Answered on March 31, 2018 at 02:53 AM

    We are sorry for the trouble caused. We our support team from different locations have tested the form and was unable to replicate the issue and unable to guide you in the right direction to troubleshoot the issue. Did you try to submit the form at your end and were you able to replicate the issue? Also, I notice that the Save and Continue later is enabled on the form. Could you change it to AutoFill so that if the form is closed accidentally, the form data will be stored in the browser storage. This helps in restoring the form data when the form is opened again on the same browser and same PC.

    152247918731032018_1217125.png

    Thanks!