Cards Layout: FLOATING FEEDBACK BUTTON and LIGHTBOX embedding codes do not show up the pointing cursor appropriately on IOS devices

  • Profile Image
    mehriamin
    Asked on March 20, 2018 at 09:41 PM

    My users are complaining a lot that form is not compatible on iPhones. When they are typing in the forms, the cursor is not staying on the field. Images attached.

    Forms: all 

    https://form.jotform.co/80762282349866 

    https://form.jotform.co/80762475849875

    many others 

    Website: bookbeautynearby.com

    1521596556Photo 21-3-18, 12 30 32 pm.png

     

  • Profile Image
    BJoanna
    Answered on March 21, 2018 at 04:07 AM

    I asked one of my colleagues to test the standalone forms you provided, but he was not able to replicate the issue with the cursor you reported. 

    I was not able to find those forms on the webpage you provided. If the issue can only be replicated on your embedded forms, please provide us the exact URL where those forms are embedded, so that we can test them. 

  • Profile Image
    mehriamin
    Answered on March 21, 2018 at 04:10 AM

    Try on your mobile as all iOS is having problems, I've even attached picture of issue.

    Here is link to one of the forms with feedback button which has issue (but all your f forms have same problem): 

    https://bookbeautynearby.com/amanda-m 


  • Profile Image
    Victoria_K
    Answered on March 21, 2018 at 06:56 AM

    I have tested the form embedded and with it's direct URL. You're right, the cursor is not showing up approprietly when embedded, but it is via the direct link. 

    1521629390screenshotwhqc0.png

    My best recommendation will be to re-embed the form properly, you can check the list of available embedding options here:

    Which-Form-Embed-Code-Should-I-Use

    We also do have an option to embed a form as a lightbox:

    How-to-Create-a-Lightbox-Form

    Hope this helps! But, please get back to us if the issue persists.

  • Profile Image
    Victoria_K
    Answered on March 21, 2018 at 10:30 AM

    Thank you for testing the lightbox code too. It seems that we have an issue with those 2 embedding codes, I was also able to replicate it.

    This thread will now be escalated to our developers for fixing. Unfortunately, I can't provide any timeframe when this is going to be ready, but please be sure that we will keep you posted with any updates.

    Don't you want to embed the form via Iframe method per now? 

    Getting-the-Form-iFrame-Code

  • Profile Image
    berkay
    Answered on March 22, 2018 at 04:32 AM

    Hey,

    I have investigated further for the related issue.

    This issue is related to IOS 11/Safari.

    There is a bug report which is opened to the Apple about this(https://bugs.webkit.org/show_bug.cgi?id=176896).

    The related bug looks fixed by Apple/Safari development team and the fix will be distributed with IOS 11.3 version.

    I also tested it with IOS 11.3 Beta, everything looks normal. Unfortunately, there is nothing we can do for it now. We're waiting for new IOS (11.3) release.

    Best,

    Berkay.