Conditional Inputs not working on site

  • Profile Image
    cptreptile
    Asked on October 25, 2012 at 09:59 PM

    Hello,

     

    I know much of this is not supported, i am trying to cintigrate my form into a calculation wizard.

    for some reason, the conditional inputs are not hidden.

    I cant really find the reason, surely some conflict with css or java

    (though i have tried so, that i included all css and javas into a working sample, and its working there perfectly, only when copying the inputs to my page its not working.)

     

    http://www.vland.eu/beta4/wizard/index-jot.php  (slide 2 "Design" Design options is a conditional input sample)

    http://www.vland.eu/beta4/wizard/welcome-joy.html (working sample of the form - jotform code)

    would appreciate it very much for the help.

  • Profile Image
    idarktech
    Answered on October 25, 2012 at 11:44 PM

    Hi there,

    We'll see if we can help you figure it out. I think you are currently editing your slide page as I can see they are always changing when I hit refresh. I'd suggest to review first the codes from JotForm and be sure not to left anything when doing copy/paste to avoid lossing functionality. Conflict might also be the case here since you are using jquery reference but it should be working fine when you delcare noconflict. Just update us if the page is set so we can review and help you with this.

    P.S. Nicely done on the form slide, like it! :)

    Thanks!

  • Profile Image
    cptreptile
    Answered on October 26, 2012 at 12:49 AM

    Thank you for your reply :)

    Yes, i'm debugging the issue in this moment in diffrent way:-

    so far i tried to intigrate jotform code into my page, now i am trying to do the oposit - put my page code into the jotform source code.

    Jotform intigrated into my code: 

    http://www.vland.eu/beta4/wizard/index-jot.php  

    My code in jotform file:

    http://www.vland.eu/beta4/wizard/test.php

    And seems i am getting closer to the sulotion, conditionals / hints / validations are working now.

    however i have now 2 new issues: (

    1. prices should appear next to the fields, when i add this code from jotform then its hiding it:

    <code>

    <input type="hidden" id="simple_spc" name="simple_spc" value="22700138561345" />

      <script type="text/javascript">

      document.getElementById("si" + "mple" + "_spc").value = "22700138561345-22700138561345";

      </script></code>

     

    2. the other issue i think is not related to jotform i wont waste your time with it (unless i find a conflict)

     

    million thanks :)

  • Profile Image
    idarktech
    Answered on October 26, 2012 at 01:50 AM

    Hi,

    1. That sounds great! Try to wrap it with <div> this might help.

    Example:

      <div>

      <input type="hidden" id="simple_spc" name="simple_spc" value="22700138561345" />

      <script type="text/javascript">

      document.getElementById("si" + "mple" + "_spc").value = "22700138561345-22700138561345";

      </script>

       </div>

    2. Sure, we are always here to help just message us anytime. Thanks!

  • Profile Image
    cptreptile
    Answered on October 26, 2012 at 02:02 AM

    That did the trick :) what is this code exactly for?

  • Profile Image
    idarktech
    Answered on October 26, 2012 at 02:09 AM

    Not sure about the main purpose of that code but as far as I know it's used for submissions. :)

    Thanks!