Quiz App is no longer working with Number and Textbox fields

  • Profile Image
    BarnsideVet
    Asked on March 25, 2018 at 11:12 AM

    I am trying to create a quiz and the Quizform app is not allowing me to save the correct answers.  I created a sample form for testing purposes, added the Quizform app to the form, entered the correct answers, and saved the quiz.  Each time take the quiz it provides results of (0/0 0.00%).  It is not recognizing the correct answer key.  A link to the sample form is provided below.

  • Profile Image
    BDAVID
    Answered on March 25, 2018 at 01:24 PM

    Probably the issue is related to your browsers cache, please try setting it up using a different browser, or try clearing your forms cache: https://www.jotform.com/help/289-Turn-Your-Form-into-a-Quiz-or-Exam- 

  • Profile Image
    BarnsideVet
    Answered on March 25, 2018 at 01:40 PM

    I cleared the forms cache in account settings and I switched from Safari to Chrome.  Neither option corrected the problem.

  • Profile Image
    Welvin
    Answered on March 25, 2018 at 03:28 PM

    As far as I know, Quiz app won't work on Textboxes. It is only designed to work with Dropdown, Checkbox, Radio Button fields. You may consider doing it that way, to have users select the correct answer from the list. 

  • Profile Image
    BarnsideVet
    Answered on March 25, 2018 at 03:41 PM

    I have three other math test forms that are set up exactly the same way and they work fine.  In looking at reviews of the app it appears that this is a new glitch that may have started around December.  The other forms that I have were created prior to December.

    Here is an example of one that is working correctly.

    https://form.jotform.com/72931129731153

  • Profile Image
    Welvin
    Answered on March 25, 2018 at 04:29 PM

    Thank you. The form is enough to say that it works with textboxes. I haven't tried it this way before. My apologies. Let me investigate further. I may have to report this to our backend team. I'll keep you posted.

  • Profile Image
    Welvin
    Answered on March 25, 2018 at 05:01 PM

    It's not doing that way. I get the same as yours, zeros;

    I have now escalated this thread to our backend team. If we have an update, we'll make sure to let you know here. 

    In the meantime, if you urgently need to have a workaround, you may consider using our Radio Button or Dropdown. 

  • Profile Image
    NeilVicente
    Answered on March 26, 2018 at 07:27 PM

    Hi there,

    This should be fixed now, but you will have to set the answers to your form again.

    Please do try and let us know if you're still having issues.

    Thanks!