Editing submissions launches a completely new submission

  • Profile Image
    kkoskos
    Asked on October 29, 2012 at 09:55 AM

    I also contacted you last week on this matter.

    Our school uses Jotform for student disciplinary referrals.  Teachers provide us with info regarding which student is a concern and describe what the issue is.  Administrators are notified of the submission of referrals by email.  Once we have worked with the student, we go in and edit the forms to tell the teacher what consequences the student received. 

    Right now when we go in to edit a form, a completely new blank version of the form launches when you click the edit button, instead of the original submission.  This leaves us with two separate form submissions related any referral situation - one from the teacher, and then one from the administrator.  If we want to have one submission that contains all of the information related to the incident then the administrator would have to enter their information as to how they handled the matter and also retype the entire original submission, which wastes time and is inefficient. 

    When one hits the "edit form" button, all of the information that was on the original submission disappears.  A yellow triangle with an exclamation point "error on page" icon appears in the bottom left corner of the browser.  When I double click on that icon, the error message details are as follows:

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; InfoPath.2; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E)
    Timestamp: Mon, 29 Oct 2012 13:32:28 UTC


    Message: 'JotForm' is undefined
    Line: 40
    Char: 4
    Code: 0
    URI: http://form.jotformpro.com/form/23023452985959

    This problem was happening with one of the three users of our school account last week, but now it is happening to multiple users.

    Our forms, including the one on this correspondence are also not displaying properly.  Each question/prompt is displaying with a bullet point, which is unusual.  In addition, checklist questions are not displaying properly.  Instead of each item in a checklist appearing on its own line vertically, all checklist options are running together continuously from right to left, then from one row to the next.

  • Profile Image
    jeanettebmz
    Answered on October 29, 2012 at 01:27 PM

    I have read the issue you are having with the forms, like Neil said, I was not able to reproduce the issue on IE8 . I am not sure, but I would recommend you to give it a try the Edit link method rather than having users to get into my Forms page. You can setup a notification to Multiple recipients and include the Edit link in the body of the email

    Regarding to the way the form is being shown , I am able to see it correclty

    As shown on this image

  • Profile Image
    kkoskos
    Answered on October 29, 2012 at 03:13 PM

    The problem continues to persist and I am unable to add the edit link command to my forms.  I don't see anywhere where I can or am supposed to do it and have no way to attach a screenshot ... There is no "update your entry" field available to me in my notification email window.  Is there a phone number I can call for support?

     

    As a side note - everything was working just fine until last week ... is there an update to the software I am unaware of or something along those lines?  Our forms are not displaying properly on desktop computers or Ipads either ... I'm not sure why you are not experiencing any issues and we're experiencing a ton ...

     

  • Profile Image
    jeanettebmz
    Answered on October 29, 2012 at 03:40 PM

    Unfortunately , we don't provide phone support as for now.

    The  edit link should be included into the body of the email notification that should be sent to the users in charge of updating a submission. Please check the link  for further details.

    Have you cleared the browsers cache on those computers/pads?

    Also, can you please tell me if you have embedded this form into a page?  I would recommend you to change to http://www for those forms in the http://form.jotformpro.com