How to remove JotForm branding?

  • Profile Image
    streakbettor
    Asked on March 29, 2018 at 01:36 PM

    How do I remove JotForm branding in my form and in the emails? I have a paid subscription already and JotForm still appears in my stuff.

  • Profile Image
    Nik_C
    Answered on March 29, 2018 at 02:44 PM

    Please follow this guide: 

    1) Go to Settings page https://www.jotform.com/myaccount/settings

    2) Uncheck this option:

    1522349058Screen Shot 2018-03-29 at 8.42

    If you have any further questions please get back to us.

    Thank you!

  • Profile Image
    streakbettor
    Answered on March 29, 2018 at 03:43 PM

    I tested my autoresponder email and the sender shows as "Jotform (
    noreply@jotform.com)" as shown below:
    1522368757jf.png
    I have already specified a "verified" email in the Advance settings. I set
    to "win@streakbettor.com" but not working
    ...

  • Profile Image
    Victoria_K
    Answered on March 29, 2018 at 04:49 PM

    Unfortunately, we cannot see images attached to your email reply. 

    How-to-Post-Screenshots-to-Our-Support-Forum

    But, from what I can read, I suppose the issue is cache related. I have now cleared your form caches, can you kindly check if the Autoresponds are correct now?

    We will gladly assist if you need more help.

  • Profile Image
    streakbettor
    Answered on March 29, 2018 at 08:11 PM

    1522368703jf.png

  • Profile Image
    Kiran
    Answered on March 30, 2018 at 12:41 AM

    As I check the screenshot provided, I notice that you are clicking on Test email button in the email autoresponder. Please be noted that the test emails shall be sent to the account registered email address and uses JotForm default email address as the sender email.

    Please try submitting the form normally so that the email autoresponder shall be sent using the custom email address.

    Thank you!

  • Profile Image
    streakbettor
    Answered on March 30, 2018 at 04:43 PM
    Thank you for the response.
    My form requires the Credit Card information for it to be submitted. If I
    test it normally from within my site, it will utilize 1 out of my 10
    payments for the month ( I have a Bronze Package).
    Is there a way for me to check my "Sender Email" is working correctly
    without using my limited number of payments?
    Thank you

    ...
  • Profile Image
    John_Benson
    Answered on March 30, 2018 at 08:59 PM

    We have a policy of one question per thread. I decided to move your new question to this thread: https://www.jotform.com/answers/1431157

    Please wait for my reply shortly. Thank you.