Form conditions not working

  • Profile Image
    STEPllc
    Asked on March 29, 2018 at 05:58 PM

    Hello, 

    I have a condition on my form to hide or show the next question based on their answer, however this is not working. The form was working properly until today. Can you help? The issue is with the following conditions: 

    1522360651conditions error.png

    Thanks for your help! 

  • Profile Image
    BDAVID
    Answered on March 29, 2018 at 08:58 PM

    Try removing the hide condition. Please note that there is no need to setup a second condition to hide the field if the first condition, where the field is supposed to show, is not met.

  • Profile Image
    STEPllc
    Answered on March 29, 2018 at 09:42 PM

    I have found having that field is necessary. If the person filling out the form selects the option that shows the next field, but then changes their mind and selects a different answer, the form will still show the next field as dictated by the condition.

  • Profile Image
    BJoanna
    Answered on March 30, 2018 at 04:26 AM

    To resolve the issue with the field that remains shown when the users change their mind and select a different answer, you have to set Clear Hidden Filed Values to Clear on Being Hidden inside of the form settings. 

    1522397687clear.JPG

    With this setup, you can delete the hide condition like my colleague suggested. 

    Here is my demo form without the hide conditions and with the setup from the screenshot above: https://form.jotform.com/80881961440965 

    Feel free to test it and clone it

    Feel free to contact us if you have any other issue or questions.

  • Profile Image
    STEPllc
    Answered on March 30, 2018 at 10:01 AM

    Thanks for your help!