How is information showing up in a hidden field?

  • Profile Image
    strongtowerranch
    Asked on March 29, 2018 at 06:18 PM

    I have the fields at the top of the form hidden from those submitting. When I see a new submission, a couple have had information typed in the one hidden field. How is this possible? It seems that the one could've only been put there by the person submitting.

    This screenshot shows an email address. It doesn't belong there if it was somehow randomly placed there. The previous one had the parent's initials, same as by the signature on the form.

    These fields don't show when I go to the website and click on the form link to fill out the form. 

    I thought the info in those fields would be for office use only, not available to the submitters.

    Thank you for your attention to this matter.



  • Profile Image
    John_Benson
    Answered on March 29, 2018 at 09:16 PM

    This is possible if someone Edit the Submission. Please try removing the {edit_link} in the Autoresponder Email to avoid editing their submission.

    Here's a screen capture of my test:

    1522372533Sample_edit_001.gif

    I hope this information helps. Let us know if you need further assistance.

  • Profile Image
    strongtowerranch
    Answered on March 29, 2018 at 10:39 PM

    Thank you. I did not have the edit link on the auto responder when I had received the first applications/form submissions. I added it later and then deleted the edit link a couple days after I had put it on the auto-responder. Then this happened again. 

    I just now deleted the previous auto-responder and created a new one. It doesn't have the edit link on it I believe. However, it does show all the hidden fields. I thought they were not on the auto-responder body.

  • Profile Image
    strongtowerranch
    Answered on March 29, 2018 at 10:47 PM

    I did just go to the auto-responder and edit the body by selecting the fields that are supposed to be hidden and deleted them.

  • Profile Image
    gizem
    Answered on March 30, 2018 at 06:40 AM

    You can see your hidden fields on autoresponder e-mails template like this:

    1522405744Screen Shot 2018-03-30 at 1.18

    But they are not shown on the sent e-mails since they are hidden on the form. Also, hide empty fields option is set as default.

    1522405840Screen Shot 2018-03-30 at 1.18


    I have cleared your form caches. Please make sure you do not have edit link on your e-mail template. If the issue still persists when the edit link does not exist on your e-mail template, please let us know. So, we can escalate this problem to our development team.


  • Profile Image
    strongtowerranch
    Answered on April 04, 2018 at 05:55 PM

    Just received this submission and it has an email in the "Person managing this vol's application..." field. How did it get there if the field is hidden and there is no edit link on the autoresponder?

    1522878230hidden fields issue.JPG

  • Profile Image
    Welvin
    Answered on April 04, 2018 at 08:24 PM

    It looks like the submitter had an autofill on his browser. It is the only clear reason I could think since no edit was made based on our logs. How do you fill the hidden fields? Is it through submissions page edit or the edit link? 

    I was thinking to modify the hidden fields and have them shown based on conditional logic. I'm sure this will fix it. Let us know. 

  • Profile Image
    strongtowerranch
    Answered on April 06, 2018 at 01:52 PM

    I go to the form submissions and then the edit button in the top right to make additions to the hidden fields.

    I don't want the hidden fields to be shown for anyone except admin, for office use only.

  • Profile Image
    Welvin
    Answered on April 06, 2018 at 02:27 PM

    I see. Thank you for confirming. Since you are editing through the submissions page, I would suggest using the hidden box widget instead of the short text entry field. That is way easier than doing it conditionally.

    https://widgets.jotform.com/widget/hidden 

    You are already using this for the Status box. This should work, and will not be filled with browser's autofill settings.