Salesforce: Some leads are not goig through to salesforce

  • Profile Image
    Miguel342
    Asked on April 04, 2018 at 10:21 AM
  • Profile Image
    John_Benson
    Answered on April 04, 2018 at 11:42 AM

    Please try re-integrating Salesforce to your form by following this guide: https://www.jotform.com/help/271-Flexible-Data-Integration-With-Salesforce

    If the issue still persists, please provide the form link and more details so we can assist you properly.

    Thank you.

  • Profile Image
    Miguel342
    Answered on April 04, 2018 at 01:45 PM

    https://www.jotform.com/build/73387281784166

     

    Here's the form, the integration is set up but some of the leads are not going through.

     

    I can send you over the responses that didn't make it through if that helps

  • Profile Image
    Adrian
    Answered on April 04, 2018 at 02:48 PM

    I can see that the Duplicate Check option in the Salesforce integration on your form is set to Use SalesForce Duplicate Rules. This means that if Salesforce decides that a submission is a duplicate (such as having the same email address), the lead won't get saved.

    15228674961.png

    I noticed that you have made lots of tests using duplicate information.

    15228676002.png

    I suggest you set the Duplicate Check option to Always Update Existing Entry.

    15228676283.png

    If you are still having problems, please try removing the integration completely and adding it again.

    I have cloned your form and the leads seem to be coming immediately.
    Cloned Form URL: https://form.jotform.com/80935808816972