Why isnt my condition working properly?

  • Profile Image
    RightHandMrs
    Asked on April 07, 2018 at 08:16 AM

    Good Morning Jotform Family,

    I created an agreement for a client. However, I would like for the autoresponder to go out once the Provider's Signature has been filled. 

    I created a condition with these details yet I'm not getting the autoresponder during my test once I've gone through the steps of clicking the edit link in the notification, then adding the Access Key and finally signing the Provider's Signature. Can you help in this matter, please?

    Actually, 1 more thing.

    When I set up the condition, the email didn't automatically populate. I had to search the input for the actual input field which is for the Client's email.
  • Profile Image
    Mike_G
    Answered on April 07, 2018 at 12:45 PM

    I was able to reproduce the issue you are having when I made a test on a clone version of your form. After investigating the form further, I found where the issue is. Based on how the form is set up, the email autoresponder is only sent when the form in edit mode is submitted because that's the only time the Provider's Signature is visible on the form. However, the email autoresponder in the form is not being sent even after the condition associated with it is met because the "Send on edit" option under the Advanced tab of the email autoresponder is not enabled.

    1523119147t12_27_58.png

    Please enable that option so that the email autoresponder will be sent if the form is submitted in edit mode.

    As for your other concern,

    When I set up the condition, the email didn't automatically populate. I had to search the input for the actual input field which is for the Client's email.

    I have moved it to a new thread to avoid confusion.

    Here's the link to that thread — https://www.jotform.com/answers/1438120

    We will be posting a reply there, shortly.