Form won't submit when clicking the submit button

  • Profile Image
    sweetips
    Asked on April 09, 2018 at 11:14 AM

    hi, I have been using your services for years with a same form format. However, the submitting button is not function recently. When clicking the submit button, the button shows “please wait” and hold for more than 15 mins and no thank you page can to directed to. Can you advise?


    Karen 

  • Profile Image
    david
    Answered on April 09, 2018 at 12:48 PM

    I cloned your form to test it and everything appears to be functional on my end:

    1523292443Capture.PNG

    If the form is embedded to a web page, try replacing the current embed code with your form's iFrame code:

    https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    If that is not the case, let us know if it is acceptable to send a couple test submissions through your form to confirm whether or not your copy if functional.

  • Profile Image
    sweetips
    Answered on April 15, 2018 at 12:38 AM

    I tried several times but the submit function is still not working and many of my customer also tell me they cannot direct to the thank you page by seeing "please wait" shown on the button.

    I also tried to remove the button and set a new submit button on my form. However, the problem still exist. please advise. 

  • Profile Image
    EltonCris
    Answered on April 15, 2018 at 03:42 AM

    I was able to reproduce it here. The form won't submit and it is throwing an error.

    When I checked your form, I found lots of conditions with missing fields. This is probably the reason why the form won't submit. To fix it, delete the conditions with missing fields in your form.