My form does not send an autoresponder email

  • Profile Image
    Upravlenie_kachestvo
    Asked on April 10, 2018 at 05:47 AM

    My form does not send an autoresponder email. It was all good just until today, but now it has stopped working for some reason.

    Link to the form - https://form.jotformeu.com/80011959304350


  • Profile Image
    Scott
    Answered on April 10, 2018 at 07:41 AM

    Hey there,

    I've checked the mail logs of your main account and was not able to locate an email that was failed to send.

    Also, I've checked the latest autoresponder receivers if they are in the bounce list or not and they were all clear.

    Lastly, the last Notification plus Autoresponder couple was sent today without a problem 20 minutes ago.

    Are you still having any issues? Have you checked your spam folders?

  • Profile Image
    Upravlenie_kachestvo
    Answered on April 10, 2018 at 08:31 AM

    Yes I do indeed still have some troubles. The one in the red is the last completed form and the person has not received any confirmation email yet.

    152336351611.jpg

  • Profile Image
    Adrian
    Answered on April 10, 2018 at 09:08 AM

    The email for that submission is showing as Sent in our logs.

    15233656201.png

    You can check the Email History for your account as well.
    How to View All Your Form Email History

    Please advise the person to check the Spam folder and if the Email is there make sure to mark it as Not Spam.

  • Profile Image
    Upravlenie_kachestvo
    Answered on April 10, 2018 at 09:30 AM

    Hi,

    The person has checked their spam folder and the email is not there either.

    Plus I only have one email on my history and it hasn't been sent to the participant but as a notification to my email.

    152336687312.jpg

  • Profile Image
    Upravlenie_kachestvo
    Answered on April 10, 2018 at 09:40 AM

    Turns out it is all good when I used my personal email. The problem is that those who fill the form will not use their personal emails but the company's ending on @econt.com

  • Profile Image
    Victoria_K
    Answered on April 10, 2018 at 10:21 AM

    From your last update, we can also suggest to contact your email service provider and request them to add JotForm's IP addresses to their whitelist. 

    Here is a full list:

    Whitelisting-JotForm-IP-Addresses-and-Domains

    There is also another option if you are not completely happy with our email sending facility - to add your own SMTP sender. All emails will be sent using your own server. 

    How-to-Setup-SMTP-for-a-Form

    Hope this helps.

  • Profile Image
    Upravlenie_kachestvo
    Answered on April 11, 2018 at 11:01 AM

    Hi, I spoke to those who provide our email service and they told me to ask you whether you see a specific problem in regards to the emails that have been sent 

    They said that the IP address should not be a problem as we receive emails from noreply@jotform.com when the first part of the form is completed but do not when the second is.

    Is there any specific error when it comes to the second email that has to be send because we do not receive it?

  • Profile Image
    Scott
    Answered on April 11, 2018 at 11:30 AM

    First of all email logs we have mentioned belongs to the main account and due to that, you cannot see them through your account.

    Secondly, if an email is shown as SENT in our logs, the only part left to blame is the possible wrong setup of an SMTP server.

    When I checked into the form in question, I cannot see any SMTP emails. Have you removed them? Since some of the logs show that the sender is not noreply@jotform.

    1523460587Screen Shot 2018-04-11 at 18.2

  • Profile Image
    Upravlenie_kachestvo
    Answered on April 16, 2018 at 06:35 AM

    Hi again,

    Sorry for bothering you again, but I am still having issues with the autoresponder email (regarding this form - https://eu.jotform.com/build/80011959304350 ). It suddenly started working for a bit last week but today the problem emerged again. Please sort it out because it is important for me to have all the emails sent to those who have completed it!

    I don't know where the problem is but it can't be in the IP address as I spoke to a guy that has completed the form 5 times in the last couple of days and only had 2 emails back. Which means the IP is fine as he still gets some of the emails.

    I have also tried to look up the history of the emails that have been sent as you suggested on your previous answer but it only shows one for this month so I guess there is a problem too.

    I hope we sort this out quickly because it directly affects the work of two departments in my company.

    Thanks in advance.

  • Profile Image
    Scott
    Answered on April 16, 2018 at 07:50 AM

    I also mentioned that you cannot see the history from your account but only from the main account, EcontExpress.

    Again when I check the history records, the story remains the same.

    What I need from you for a more in-depth check is, a submission's ID which you received the notification but the submitter did not receive autoresponder.

  • Profile Image
    Richie_P
    Answered on April 16, 2018 at 11:24 AM

    Checked the submission you have given and the email was sent to the user.

    Here is the screenshot on the mail log.

    Please do you check back to your email service provider as that emails are sent and whitelist our IP addresses and domains. You can check them here,-Whitelisting-JotForm-IP-Addresses-and-Domains

    You could also setup an SMTP to use your own mail server.

    -How-to-Setup-SMTP-for-a-Form

    Hope this information helps.


    Please let us know if we can be of further assistance.

  • Profile Image
    Upravlenie_kachestvo
    Answered on April 17, 2018 at 06:55 AM

    I have one more question.

    After I spoke once again with our email service provider he told me that 'sendmail' is something like an intermediate hub (between Jotforms and our email system) that receives the email sent by you and then resend it to the end user - someone who has filled our form. Apparently the error comes from that point where 'sendmail' has to send the email to the end user.

    So would it be possible for you to have a look at the sendmail logs if there is something wrong?

  • Profile Image
    Scott
    Answered on April 17, 2018 at 08:18 AM

    Hey,

    Forwarded this info to our DevOps team for a check. They will be informing you when they have the chance to look into it.

  • Profile Image
    uygar
    Answered on April 17, 2018 at 10:00 AM

    Hi, 

    We checked our smtp logs and found out that there is no problem at our end. Here is the logs our smtp server:

    This is Autoresponder entry of submission id 399588477577192587 at  2018-04-15 05:38:24 

    noreply@jotform.com, Upravlenie Kachestvo

    ivan_karashanov@econt.com

    We have received your response for

    2018-04-15 06:38:32

    80011959304350

    3995884775771925877

    Upravlenie_kachestvo@econt.com


    This our STMP Server log for your autoresponder email.  

    Apr 15 06:38:35 seo-pool1 postfix-129.121.212.180/smtp[118111]: 7E68E1AA0438: to=<ivan_karashanov@econt.com>, relay=mail.econt.com[213.91.197.11]:25, delay=2.7, delays=0.41/0/1.1/1.2, dsn=2.0.0, status=sent (250 Queued id=0x20963630)

     

  • Profile Image
    Upravlenie_kachestvo
    Answered on April 18, 2018 at 10:04 AM

    Hi again,

    I spoke to our email service provider and they allowed all your IP addresses so now the problem with the autoresponder emails has been sorted. But unfortunately another problem has emerged.

    Now the form has started to crash and the users are asking me what is going on sending me different screenshots.

    1524060062paaobhkgjcdjdpnc.png1524060120viber image.jpg1524060084bcgpmmhmekknnlbi.png

  • Profile Image
    Adrian
    Answered on April 18, 2018 at 11:18 AM

    Your last question about the errors on form submission has been moved to a new thread to avoid confusion and it will be answered shortly.

    Link to the thread: https://www.jotform.com/answers/1448765