Having issue making the Show/Hide Field condition in my form

  • Profile Image
    corporatevents
    Asked on April 12, 2018 at 10:49 AM

    Dear Jotform Team,

    I just try to hide the rest of my form from the field "Je participe au store..." which is a single choice, I put a condition on the no (non) and yes (oui) to be sure it going to show and hide the different fields. 

    The objectif of this is to show and hide a long form e.a. If you don't want to come to an event and you say "Non"  to the field "Je participie" then ther is no reason to see the rest of all the fields after that question.

    I don't understand why it doesn't work. Can you help me ?

    Thanks for your precious help

  • Profile Image
    BJoanna
    Answered on April 12, 2018 at 12:28 PM

    The condition for the "Non" option is not working because of the conflict with your other condition that is set to show all form fields. 

    1523549824condition.JPG

    Please note that you do not have to create duplicate conditions for both options, like in equal to fixe600pxby900px and not equal to fixe600pxby900px. One condition is enough. 

    If you delete the condition from the screenshot above, you form will work. You can also delete/ disable the condition for "Non" option. 

    Here is my form with only two conditions - https://form.jotform.com/81014405904952?pagesize=fixe600pxby900px 

    Feel free to test it and clone it

    Hope this will help. 

  • Profile Image
    Mike_G
    Answered on April 13, 2018 at 12:38 PM

    Thank you for clarifying your concern using examples we appreciate that.

    To fix the issue, here's what you need to do.

    But first, make sure that the Continue Forms Later option of your form is DISABLED.

    1523637049t12_29_33.png

    Then, after that edit this condition in your form:

    1523637170t12_32_31.png

    And include this:

    1523637233t12_33_07.png

    Here's a sample form where I have applied the changes above:

    https://form.jotform.com/81024613973960

    https://form.jotform.com/81024613973960?pagesize=fixe600pxby900px

    If the form is accessed and the pagesize field is not equal to fixe600pxby900px by default, then it will just show the Form Not Found image and hide the rest of the form fields.

    I hope this helps. If you have other questions or concerns, please feel free to let us know.

  • Profile Image
    corporatevents
    Answered on April 14, 2018 at 05:13 AM

    Hi Mike,

    Thanks for your help, it's a little better but we still have 2 problems :

    1) In the field "Je participe..." if we click on "Non" then you see at the end of the form the image "Page not found". That visual should only visible when the form is accessed and the pagesize field is not equal to fixe600pxby900px.

    15236971561442653 - Clone of Store Check

    2) I have now error messages in the build :

    1523696986The Easiest Online Form BuildeI'm working now with this form :

    https://form.jotformeu.com/81032357313346

    https://form.jotformeu.com/81032357313346?pagesize=fixe600pxby900px

     I forgot to mention that I work with the last version of fireworks for Mac.

    PS : Less important but just for the info, if I control the same page in safari for Mac in the build section I dont see any circle to make the selection for my differents Multi choice questions but I see them correctly with the advanced designer tool.

  • Profile Image
    Mike_G
    Answered on April 14, 2018 at 09:20 AM

    For your question #1, it can be fixed by removing this action

    1523711681t09_04_02.png

    from this condition.

    1523711702t09_04_26.png

    Here's another test form — https://form.jotform.com/81033641273954

    https://form.jotform.com/81033641273954?pagesize=fixe600pxby900px

    As for your question #2, I have checked the form in your account directly and I have not seen the error message you showed us in the screenshot you shared. Perhaps that issue was just temporary. Otherwise, please feel free to let us know and provide us with more details.

  • Profile Image
    corporatevents
    Answered on April 15, 2018 at 04:22 AM

    Hi Mike,

    That's perfect, everything works so fine now :-) I still have this problem with safari (see the screenshot beneath) but it's not a big deal, in firefox everthing is ok.

    Thanks for your precious help, also thank you for your help Johanna.

    1523780526screen2.jpeg Image JPEG 1324