Payments: User defined amount

  • Profile Image
    philidenning
    Asked on April 13, 2018 at 07:43 AM

    Hi,

    I'm trying to get the payment section on my form to take an amount from a previous calculation and have selected 'user defined amount' but that amount is not showing in the my products box as the total to pay.

    What have I missed?

    https://eu.jotform.com/build/80772620710350#preview

  • Profile Image
    gizem
    Answered on April 13, 2018 at 10:58 AM

    As far as I check your form, you missed setting the 'Get Price From' option for your payment field.

    I can suggest you follow this guide: How to Pass a Calculation to a Payment Field

    Give it a try. Let us know how it goes.

  • Profile Image
    philidenning
    Answered on April 13, 2018 at 11:04 AM

    Thanks for that but even when I select Get Price From and the correct field to get it from, it does not work. The settings also seem to change even though I click save after making the changes.

    I've just tried again.

    I've also tried doing it in test mode and in live mode but still can't get it to link up to the correct field or to save the changes I am making.

    Any other thoughts. Thank you.

  • Profile Image
    Richie_P
    Answered on April 13, 2018 at 12:38 PM

    I have checked your form and it seems you have not assigned the get price to any calculation field.

    When I assigned the get price to a calculation field the settings was saved.

    Here is my screen cast:

    Make sure you are connected to stripe even if you're just testing your form.

    Let us know if the issue still remains.



  • Profile Image
    philidenning
    Answered on April 13, 2018 at 12:57 PM

    Thanks for the reply. That is what I am trying to do but it is just not working.

    Whenever I open the form and go to the payment section, it has always reset itself to Get price from 'None, manual'. I always click save.

    I am also always lose the connection to stripe. When I reconnect and then select Get price from: amountpayable30, then click save the stripe integration box disappears. When I next click on the wand, the settings I have tried to save are gone, connection is lost to stripe and get price is back to 'None, manual'

    Is there anyone I can talk it through with over the phone?

  • Profile Image
    Richie_P
    Answered on April 13, 2018 at 02:13 PM

    Unfortunately, we do not have phone support.

    Have you tried using other web browsers? Maybe your connection was lost when you Integrated Stripe and updated the Get Price.

    Can you try to use Live mode and see if the issue on disconnection remains?

    Please give it a try and let us know how it goes.

    Thank you.