My forms are not listed in the section my forms on the website. HELP!!

  • Profile Image
    dawnhendrix
    Asked on November 06, 2012 at 10:06 AM
  • Profile Image
    WilnerFirm
    Answered on November 06, 2012 at 10:10 AM

    I am also experiencing this problem. They show up in the bottom right footer but I need them in the main section of "my forms" so I can duplicate one of them. Hopefully just a temporary bug.

  • Profile Image
    dawnhendrix
    Answered on November 06, 2012 at 10:18 AM

    Is there a number to call JotForm?  I need this fixed ASAP.  I have work due!!

  • Profile Image
    premiersmi
    Answered on November 06, 2012 at 10:20 AM

    Support, We Need An Answer!!!

  • Profile Image
    thijs
    Answered on November 06, 2012 at 10:21 AM

    HELP!!! I have the same problem here, blank screens!!!

  • Profile Image
    mariebradshaw
    Answered on November 06, 2012 at 10:22 AM

    Same problem here. Need forms asap.

  • Profile Image
    ebizz
    Answered on November 06, 2012 at 10:25 AM

    same problem here !!!

  • Profile Image
    liyam
    Answered on November 06, 2012 at 10:28 AM

    Hello guys.  Are you all using the new My Forms page layout, or the old one?  Have you tried pressing the switch to old version tab at the bottom?

  • Profile Image
    mariebradshaw
    Answered on November 06, 2012 at 10:32 AM

    I see no such option.

  • Profile Image
    jmbullis
    Answered on November 06, 2012 at 10:33 AM

    I do not see this option anywhere! HELP CEO is expecting me to have something done and can't do it because of this issue!

  • Profile Image
    shaunnaylor
    Answered on November 06, 2012 at 10:34 AM

    My forms are not showing either, is it just a tech. glich  hope so!

     

    Regards

     

    Shaun

  • Profile Image
    mariebradshaw
    Answered on November 06, 2012 at 10:35 AM

    FYI, I was told on my forum post to go to jotform.us and log in there. That didn't work.

  • Profile Image
    bradleyumane
    Answered on November 06, 2012 at 10:37 AM

    SAME PROBLEM... THIS IS UNACCEPTABLE

  • Profile Image
    idarktech
    Answered on November 06, 2012 at 10:37 AM

    Hi guys,

    Thanks for reporting.

    Let us please inform you that we have already notified our developers about this. We'll update you here right away once we heard back from them. I'm sure this wont take long.

    Sorry for this inconvenience.

  • Profile Image
    cmoran7
    Answered on November 06, 2012 at 10:44 AM

    Despite my form disappearing,  It 'does' looks like URL's to forms are still working and attachment submissions are still being routed to Dropbox and Gdocs.

  • Profile Image
    aytekin
    Answered on November 06, 2012 at 10:47 AM

    We had a bug on My Forms page that caused the forms to not show up. It is fixed now. Thank you for your patience. 

    Sorry about this. We are getting ready to release the brand new version of the My Forms page. 

  • Profile Image
    edreamdesigns
    Answered on November 09, 2012 at 10:40 AM

    I'm still not seeing my forms and wehn I click the button to 'switch to old form' it doesn't work.

  • Profile Image
    Welvin
    Answered on November 09, 2012 at 10:58 AM

    @edreamdesigns,

    Clearing your browsers cache migh help. Please try and let us know if that helps you or no.

    Thank you.

  • Profile Image
    edreamdesigns
    Answered on November 09, 2012 at 11:03 AM
    Yeah did F5 and Ctrl F5 and still is blank. I am logged in I think, if I click the Jotform logo on upper left side and scroll down on the page where you put in your login info, i see a few of the most recent forms listed there...



  • Profile Image
    NeilVicente
    Answered on November 09, 2012 at 11:15 AM

    @edreamdesigns

    Your browser might have JavaScript turned off. Kindly enable it by following the directions on the following site: http://www.activatejavascript.org/

    If it does not help, try using a different browser so we can know for sure whether the problem is browser-related or not. If the problem still persists, may we ask you to open a new thread so we can focus on your issue?