JotForm API: Problem with JFCustomWidget ready event

  • Profile Image
    Cho 
    Asked on June 03, 2018 at 02:52 PM

    Hello,

    By the time I register to the "ready" event with "JFCustomWidget.subscribe", the event already fired. and the callback is never called.

    I cant figure out why and I even tried to include the exact same code as https://js.jotform.com/samples/drawingboard/ without success. The console log is not called there either.

    Do I have to check if the form is already ready before subscribing to the event ? And if so, how ?



  • Profile Image
    jonathan
    Answered on June 03, 2018 at 06:08 PM

    It will help us in fixing the issue if you share to us the URL link of your form that have the problem. I was not able to identify your username and form using the email account you used on this post.

    We will wait for your updated response.

  • Profile Image
     
    Answered on June 03, 2018 at 06:22 PM

    Try this one http://form.jotformeu.com/81503593392358

    Thank you.

  • Profile Image
    jonathan
    Answered on June 03, 2018 at 07:50 PM

    First, I suggest you log in to your account/username Cho at JotForm here https://www.jotform.com/login

    I did checked your form and it appears to be an empty form only.

    1528069601zzz 2018-06-04 07.44.29.png


    It appears that your account had become dormant due to long inactivity. I have to re-activate your account initially.

    To fix the empty/blank form, you may add back the Drawing Board widget again.

    1528069847zzz 2018-06-04 07.49.17.png


  • Profile Image
    cho_rcp
    Answered on June 04, 2018 at 08:15 AM

    Ok, I created an account. I dont know what account you activated but it's not mine. I had no account, I was just testing on the form of a customer of mine.

    Anyway, you do not understand my problem it seems.

    I don't care about the Drawing Board widget. I'm just using his code in my iframe widget to show you that the "ready" event callback is not called. The "console.log" line is not reached.

    Here is the new form created with my account: http://form.jotformeu.com/81543231715350

    And it is not empty. It contains an Iframe embed widget.


  • Profile Image
    aubreybourke
    Answered on June 04, 2018 at 11:11 AM

    You are using the JotForm API right?

    Please direct your API related questions to api@jotform.com


  • Profile Image
    cho_rcp
    Answered on June 04, 2018 at 11:28 AM

    Ok, will do, thank you.

  • Profile Image
    cho_rcp
    Answered on June 25, 2018 at 11:54 AM

    Nobody ever answered my emails over there :(

    Any other way to contact them ?

  • Profile Image
    aubreybourke
    Answered on June 25, 2018 at 12:04 PM

    Unfortunately there is no other way to reach out to the api team. Its possible that they are just too busy. Please give them some more time to respond, and maybe email them once again?