How do I achieve Google Drive integration, with file upload?

  • Profile Image
    agneshawthorne
    Asked on November 24, 2012 at 06:20 PM

    Google drive integration not working correctly, as uploaded files just stay in the JotForm submission list and do not get submitted to my google drive. I have followed the process to integrate my google drive and it say it is 'connected' however when I submit the form (as I'm only testing currently),

     

    - the notification email doesn't reach my gmail account.

    - the uploaded file goes to the JotForm submission list where I can access it, but it does not get pushed to my Google Drive.

    - After submitting the form, it shows a 2nd Captcha, which I didn't add to the form

    - it also doesn't show my Thank you message, even though one is set.

     

    Help,

     

    Thanks,

     

    Agnes

  • Profile Image
    NeilVicente
    Answered on November 24, 2012 at 06:45 PM

    Hello Agnes,

    Let me answer your issues to the best of my knowledge:

    - the notification email doesn't reach my gmail account.

    Your notification's recipient email is empty.

    Here's how to change it: http://www.jotform.com/help/41-Finding-out-E-mail-Address-used-for-submission-notifications

    - the uploaded file goes to the JotForm submission list where I can access it, but it does not get pushed to my Google Drive.

    Try redoing the form's integration to Google Drive. Get back to us with your results.

    - After submitting the form, it shows a 2nd Captcha, which I didn't add to the form

    The second captcha appears only if the original captcha (on the form) is not filled out properly.

    - it also doesn't show my Thank you message, even though one is set.

    I am not able to reproduce this problem on my end. Thank you message displayed fine after I submitted your form:

  • Profile Image
    agneshawthorne
    Answered on November 24, 2012 at 07:08 PM

    Hi, 

     

    I have added my email address and sent a test email successfully, however, when I upload a file via the form, it still only goes to the Jot Form list.

    I have disconnected my Google Account and reconnected it. It created the right folder, but didn't receive the uploaded file.

    The second captcha appeared again and the msg didn't, it just leaves a blank area, after the 2nd captcha.

    (Note, I have entered the word correctly on the captcha and I don't have caps lock on.)

     

    Still not working?

     

    Any other ideas?

     

    Cheers

  • Profile Image
    Welvin
    Answered on November 24, 2012 at 08:18 PM

    Hi,

    It seems that I was able to reproduce the said issue with regards to the Google Drive Integration. This is because of the second captcha attempt even if you enter the right codes. I think this is a glitch so I will forward this to our Level 2 Support/Developers for appropriate action.

    For the main time, please try using re-Captcha field as it does work when I test it with a clone version of your form.

    -----------------

    The second captcha appeared again and the msg didn't, it just leaves a blank area, after the 2nd captcha.

    -As mention above, this is a glitch and we are sorry for this. You also can't see the thank you message because of the the captcha field showing on second page.

     

    Thanks for reporting and we do apologize for the confusions, if any.

  • Profile Image
    mtlscouts_committee
    Answered on November 27, 2012 at 01:21 AM

    I too am having this problem, and eagerly await a fix.

    Thanks in advance.

  • Profile Image
    liyam
    Answered on November 27, 2012 at 01:58 AM

    Hello mtlscouts_committee.  Can you explain your scenario on how this happens on a new thread?  But if the case is about how Welvin explained on how he was able to replicate the problem, there's no need to start a new topic.

    We'll let you know as soon as we have progress on this matter.

    Thanks for your patience.

  • Profile Image
    mtlscouts_committee
    Answered on November 27, 2012 at 02:16 AM

    I had the same problem.  Second captcha showing up, no upload to google, and then no thank you.  I switched to re-captcha, and it solved the problem for now.  However, I would like to go back to the basic captcha if/when the issue is resolved.

    Thanks;

    Arto

  • Profile Image
    liyam
    Answered on November 27, 2012 at 02:41 AM

    Thank you for this information, Arto. We'll let you know as soon as we have updates on this matter.

    Thanks.