What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    When Default Time is Changed, no Date in February can be Selected without Triggering an Error

    Asked by guest_23175212200032 on November 26, 2012 at 01:27 PM

     

     

    The URL is http://www.gandtexecutive.co.uk/ADP_Private_se334fE_.html

     

    But no date in February can be selected. Can you help please?

    Page URL:
    http://www.gandtexecutive.co.uk/ADP_Private_se334fE_.html

  • Profile Image

    Answered by guest_23175212200032 on November 26, 2012 at 01:40 PM

    Ther problem here seems to be Feb 2013? When i change it to any other month the date is fine? Can any one help? thank you in advance.

  • Profile Image

    Answered by guest_23305376687057 on November 26, 2012 at 01:54 PM

    I have also since discovered that even if you select the date from the Calender widget the date is still deemed as 'Enter a valid date' and when you try to submit the form then it says ' here are incomplete required fields. Please complete them.' If anyone can help i would be very grateful. Thank you.

  • Profile Image
    JotForm Support

    Answered by EduardoMendez on November 26, 2012 at 02:42 PM

    Hi there, 

    Can you please try the following form and see if that is what you are looking to accomplish?

    http://form.jotformpro.com/form/23306093981960?

    If so, please feel free to clone the form and use it as your own.

    Let us know if you need further assistance!

  • Profile Image

    Answered by roselaar on November 27, 2012 at 03:03 AM

    HI Jot form support,

    THank you for your reply.

     

    Even on your new form above, if you try to follow these steps. 1) Change the date to 16th Feb 2013. 2) Then change the time to 07.25. 3) THen click to the next entry and the time will be shown as invalid and you cannot procced.

    There is another post on here also about 'any future date' i think it maybe the same problem. My form populates Zohocreator so i would prefer not to change it.

    Thank you.

  • Profile Image
    JotForm Support

    Answered by abajan on November 27, 2012 at 05:14 AM

    @roselar

    I was able to replicate the issue in a form I just created for testing purposes. So, it appears to be systemwide and not isolated to your form. It seems to be somehow associated with all future Februaries but I'll need to run additional tests to be sure and then submit a ticket to have it rectified.

    In the meantime, as a workaround, you can remove the "Required" validation from the field in question and instead attach a condition to show the submit button only when that field filled. (With the help of some injected CSS, its label can be made to look like those of the other required fields.)

    The solution is used in this clone of the form which you may in turn clone. Would that be okay until we get the bug fixed?

    We look forward to your reply.

  • Profile Image

    Answered by roselaar on November 27, 2012 at 05:21 AM

    @abajan,


    Thank you - i am glad you have found the problem. I would prefer not to replcate the form becuase i have many email/population/reply/auto requests assocaited with the form and i do not wish to change it all again. I hope you can fix the issue - when do you think it will work again? thank you.

  • Profile Image
    JotForm Support

    Answered by abajan on November 27, 2012 at 05:39 AM

    @roselar

    I'll post the ticket shortly but only the developer assigned to fix the problem would be able to state when it will be fixed. What I can do is walk you through the process to get your form to function like mine:

    1. With your form loaded in the form builder, click the date field exhibiting the issue, remove its Required validation and inject the following CSS:

    #label_71:after {
    content: " *";
    color: red;
    }

    2. Create the following Show / Hide condition on the said field:


    3. Save the form if it's not autosaved


    Conditional Logic on Forms

  • Profile Image
    JotForm Support

    Answered by abajan on November 27, 2012 at 05:47 AM

    My apologies. That solution doesn't work either. Back to the drawing board!

  • Profile Image

    Answered by roselaar on November 27, 2012 at 05:51 AM

    Thank you for trying @abajan - please just update me by email when you have a solution - for us it is urgent as we are missing Feb bookings or we have to do them manually which takes a lot of time, thank you for your time in advance.

  • Profile Image
    JotForm Support

    Answered by abajan on November 27, 2012 at 05:52 AM

    Okay, will do.

  • Profile Image
    JotForm Support

    Answered by abajan on November 27, 2012 at 06:07 AM

    Just to update you:

    The ticket has been submitted and marked as urgent. It turns out that all Februaries, past as well as present, are affected. (Probably has something to do with leap years.)

  • Profile Image
    JotForm Support

    Answered by ozan on November 27, 2012 at 07:40 AM

    Hi, we've fixed the issue. It should work as expected by now. If the problem retains, pelase do not hesitate to reply this thread. Sorry for the inconvenience.

  • Profile Image

    Answered by roselaar on November 27, 2012 at 08:02 AM

    As of 13.00 GMT my form still has thew same problem @OZAN & @ABAJAN - can you check it again please? http://form.jotform.com/form/10374503506

     

    Make sure you change the time - that is when the error message comes up for Feb. All the best.

  • Profile Image
    JotForm Support

    Answered by ozan on November 27, 2012 at 08:13 AM

    @roselaar,

    Can you refresh your cache? In my end your form works with no problem. Probably this is caused of your browser cache. In chrome & firefox, ctrl+shift+R will resolve it. Thanks.

  • Profile Image

    Answered by roselaar on November 27, 2012 at 08:16 AM

    It works now - thank you very much. @OZAN & @ABAJAN