Widgets not loading and not working

  • Profile Image
    smatpages012
    Asked on July 10, 2018 at 09:42 PM

     I have tried several times to use widgets on my form, but the widgets are not just loading. I signed out and clear my cache but still the same problem.

     

    Where is the problem coming from?

    Do I need to upgrade before I can use widgets?

  • Profile Image
    Jed_C
    Answered on July 10, 2018 at 11:11 PM

    I have added an e-signature widget to this form https://form.myjotform.com/80987902747573 and it loads the widget successfully.

    1531278684widget.png

    May I know what particular widget where you trying to add that doesn't load / work? Also, please confirm which form are you working on so we can test.

    Looking forward for your response. 

  • Profile Image
    smatpages012
    Answered on July 11, 2018 at 02:08 AM

    It is happening to all my forms.

    Each time I open any of my forms on my laptop or tablet, I keep getting this message piping up at top right corner of all my forms: 

      

    Oops! Something went wrong and We couldn't initialize widget list. 
    Could you please refresh the page?
    RELOAD PAGE
    DISMISS
  • Profile Image
    smatpages012
    Answered on July 11, 2018 at 02:16 AM

    Also when I click on " widgets " at the " add elements " section ,I keep getting the message " no widgets found "

    This happens all the time on all of my forms.

    The widget I want to use is the " global countdown" widget.

  • Profile Image
    EltonCris
    Answered on July 11, 2018 at 03:55 AM

    I could not reproduce it. 

    Can you please relogin from your account and try it again?

    Perhaps the issue might be with your browser. If you have another browser, please try it there as well.

    You can also add the widgets to your form from here https://widgets.jotform.com/