Website Not Showing Form Updates

  • Profile Image
    soundscapemedia
    Asked on December 01, 2012 at 04:08 PM

    I have been noticing that when I create a form and save it, then embed it into my site, then later make changes to the form in JotForm and re-save, the website does not show the changes I made.  Maybe I'm not doing this right as I just joined Jotform.

    The only workaround I have been able to do is clone the form in JotForm then embed the cloned form into the site and then the website shows the new edits I have made to the form.  Is this a known bug or am I just doing something wrong?  Shouldn't the website automatically update when the form in JotForm is edited and saved?

    Many thanks for all your help, the support here is incredible.

    Regards,

    Jason Greenberg

    Soundscape Media Inc. 

  • Profile Image
    Deygus
    Answered on December 01, 2012 at 04:38 PM

    Hello I do apologize for this problem you are having, would you mind sharing with us the link to the mentioned form as well as your website so that we can investigate this problem for you?

  • Profile Image
    soundscapemedia
    Answered on December 01, 2012 at 06:23 PM
    Thanks for your reply. This problem is not happening with a single form, it seems to be happening with all of my forms. Here is a link to one of my embedded submission forms:
    http://www.soundscapemedia.com/soundscape/dev/html/upload_mp3.html
    Thank you,
    Jason Greenberg
    www.soundscapemedia.com
  • Profile Image
    abajan
    Answered on December 01, 2012 at 06:43 PM

    Hi Jason

    Please click the following links:

    http://form.jotformpro.com/form/23351411664952

    http://www.jotformpro.com/form/23351411664952

    If the form looks updated at the second link but not at the first, there is a failure of the server nearest to your location to refresh its content in a timely fashion. Changing the URL in src attribute of the form code embedded in the web page from

    http://form.jotformpro.com/jsform/23351411664952

    to

    http://www.jotformpro.com/jsform/23351411664952

    should fix the problem. Please do likewise with all of your other forms. (Whether they are embedded or not, change http://form ... to http://www ...)

    Please let us know if you need additional assistance with this.

    Thanks.


    Wayne

  • Profile Image
    JerryDT
    Answered on January 29, 2013 at 03:55 PM

    I'm having a similar problem with forms embedded in google sites.  Unfortunately, the workaround that has been presented won't work, as google sites will not accept that form of the url.  

     

    In other words, Google sites wants:

    http://hosting.gmodules.com/ig/gadgets/file/102235888454881850738/jotform.xml

    instead of:

    http://form.jotformpro.com/form/30284758246965

  • Profile Image
    Mike_T
    Answered on January 29, 2013 at 04:20 PM

    @JerryDT,

    I have tried to run force clear caches for your account. Please also clear cache and cookies in your browser, and then re-check your google site. I hope it helps.

    If that does not work, there is an alternative google sites embedding method. It is possible to use 3rd party Embed Gadget to embed the 'www' form. Please check my post in the following thread:

    Embedding forms on Google sites

    If you need any further assistance, please create a separate forum thread. We will be happy to help you!

  • Profile Image
    JerryDT
    Answered on January 29, 2013 at 05:52 PM

    @Mike_T
    It seems to be working now.  Fwiw, I had already tried clearing cache/cookies before I asked the question, so apparently your force clear worked.  Thanks!