Customized PDF gets reverted back to default

  • Profile Image
    chrisfrees
    Asked on August 08, 2018 at 12:08 PM

    Hello!

    I'm having an issue with the PDF report in Jotform. Basically what's happening is that I am customizing the PDF report and modifying it but I keep loosing my progress even after saving it. For some reason the form gets reverted back to the default state. Do you know what's happening with this? The form I'm building absolutely needs a customized PDF and I need this to be resolved.

    Thank you

  • Profile Image
    Kevin_G
    Answered on August 08, 2018 at 01:09 PM

    I have been testing this with a form on my end; however, I cannot replicate the issue on my end. 

    May you know which changes are you implementing to your form? 

    Also, please kindly provide us the form URL where the issue happens, this guide will help you getting it: https://www.jotform.com/help/401-Where-to-Find-My-Form-URL 

    We will clone it and further test on our end, looking forward to your response. 

  • Profile Image
    chrisfrees
    Answered on August 08, 2018 at 01:22 PM

    Some of the changes I've made are removing certain fields, I've added a small image to the header and rearranged certain fields.

    Here's a link:

    https://form.jotform.com/80786243108155


  • Profile Image
    Kevin_G
    Answered on August 08, 2018 at 02:00 PM

    Thank you for providing the link. 

    I have been testing a cloned form of yours and I can see the issue does not happen, example, I removed  the following elements while customizing the report: 

    15337510251.gif

    This is how the report downloaded: 

    15337510782.gif

    I would recommend you to try resetting the report's  layout to the default one, you will find the button on the PDF customization page, reload the page and try to perform the edits once again. 

    Please  let us  know how it goes. 

  • Profile Image
    chrisfrees
    Answered on August 08, 2018 at 04:15 PM

    Gotcha, I'll give it another try and let you know how it goes. 

  • Profile Image
    chrisfrees
    Answered on August 08, 2018 at 04:40 PM

    Well I tried reseting it but I'm still having the same issue. It's hard to understand exactly what's happening to make it do that. But it seems like it happens when I have customized, saved, and downloaded the PDF multiple times. It's like there is some bug here.

    Another thought I'm having is it may have something to do with the tabs? When I click customize it opens a new tab. From there I would close the "View Submissions" tab and then make my changes and save. Could that have something to do with it? Should I be leaving the "View Submissions" tab open as I make the revisions? Just a thought. 

  • Profile Image
    jonathan
    Answered on August 08, 2018 at 04:57 PM

    Closing the tab for the "View Submissions" on the same browser should not affect the custom PDF Report tool.

    But I think one possible reason that can cause the custom PDF reverting to default state is if there are multiple tab open for the custom PDF Report tool. 

    Let say you have multiple tabs opened for custom PDF Report tool, but only working/modifying on one tab, even if clicked Save button on that tab. It is possible when you close all the tabs, the not used tab will trigger the save also -- resulting to the custom PDF tool saving the report in default state.

    I suggest to try opening your browser in incognito or private mode. Use the custom PDF Report tool in incognito browser and make sure only one tab in the browser is open/active when working on the custom pdf report.

    I hope this help. Please let us know if issue persist even after going through the suggested procedures.


  • Profile Image
    chrisfrees
    Answered on August 08, 2018 at 05:39 PM

    Alright I'll give that a try.

  • Profile Image
    jonathan
    Answered on August 08, 2018 at 05:53 PM

    Please do. Let us know how it goes.

    Thank you