Help with Spreadsheet to Form, fields are not prepopulating properly.

  • Profile Image
    equantuminc
    Asked on August 08, 2018 at 03:10 PM

    Hello:

    My spreadsheet to form widget does not seem to be working in my Sales Order form and Contract with QNet form.  When I enter the AR number it says that it has auto filled but when I look at Software and Description on the next page it is blank.

    My column name and my question header should be the same but none of the fields are updating.  I have tried saving the file as a .xlsx, .csv and .xls to no avail.

    Please let me know what I am doing wrong.

    Thank you.

  • Profile Image
    Nik_C
    Answered on August 08, 2018 at 03:46 PM

    I checked some of the codes and some fields filled. Now, I'm not sure if only some fields are not filling for you. this is how it worked for me: 

    I used this code AR1230:

    1533757446Screen Shot 2018-08-08 at 9.43


    Anyhow, it would be better if we could have a look at your Sheet?

    This issue usually happens if the column labels are not matching the fields or if there is some extra character in column name (like empty space). 

    Are you experiencing this issue with multiple codes or only some?

    Again, if you could share your Sheet somehow (uploading it to the Google drive) that would be great so we can tet this issue.

    We'll wait for your response.

    Thank you!

  • Profile Image
    EltonCris
    Answered on August 08, 2018 at 04:55 PM

    I am using Chrome latest version (Version 68.0.3440.106) and it is working for me. I did not encounter any problem.

    15337613342018-08-09_04-46-25.gif

    Can you please try it again?

    If the problem persists, can you take a screenshot of your browser console log after experiencing the problem so we can check if there's an error? Please upload the screenshot in your thread here.

  • Profile Image
    equantuminc
    Answered on August 08, 2018 at 05:12 PM

    I got the same result so I looked at the browser console and got the result attached below.

    Thank you!

    15337627488-8-2018 2-08-11 PM.png

  • Profile Image
    jonathan
    Answered on August 08, 2018 at 05:51 PM

    Thank you for providing us with the screenshot of the browser console error as requested.

    But so far I also could not reproduce the issue including the error on the browser console using Chrome.

    Here is my screenshot of the my test using your form https://www.jotform.com/82147009062147

    1533764799zzz 2018-08-09 05.44.57.png


    As you can see there are no red error on the browser console on my screen test. It is possible the issue you were having was network related on your side.

    Can you please try also first test using an incognito mode browser. Just to be sure the issue was not browser cache caused only. 

    Please post again a screenshot of the browser console using incognito mode. This will help us checking further on the issue.

    We will wait for your updated response.


  • Profile Image
    equantuminc
    Answered on August 09, 2018 at 11:25 AM

    Thank you all. 

    I just tried it in incognito and got the exact same errors in the console and the same result on the form. 

    It sounds like the problem is with my Google Chrome setup and that most people are not experiencing the issue, so I will just work in Fire Fox and not worry about it for now. 

    Thanks again,

    Yvonne

  • Profile Image
    roneet
    Answered on August 09, 2018 at 12:05 PM

    Let us know if you have other questions in a separate thread. We will be happy to assist.

    Thanks.