Zapier: Image Picker Widget only sends the first link.

  • Profile Image
    orryakobi
    Asked on August 10, 2018 at 05:59 PM

    To whoever this may concern,

    We are having a few seriously urgent issues on the form that we created. I believe a ticket here was already created for one of the issues but the issue I am about to describe hasn't had a ticket created yet.

    The Image Picker widget is currently being used in one of our forms, Clone of Facebook Intake and Video Banner Form, as a way for the end user to select a series of 5 stock photo images for use in the video that we are creating using the form responses.

    However, when attempting to send the responses data to Zapier, only one of the stock image URLs are being sent through instead of all 5 images. I have attached an image of how its shown in Jotform. If you see under the "Select 5 Images" field, in the submission, you see multiple images selected all bundled together. But when that field data is sent to Zapier for an automation we have, only the following data comes through. See image right below. You will see a jotform link and then an S3 link.

    I am confused at what we are doing wrong and how this problem can be solved. Maybe a different Image Selector widget? Maybe a different approach using the same Image Selector widget? 

    Urgent help will be greaaaatttly appreciated.

    1533937763Screen Shot 2018-08-10 at 2.07


  • Profile Image
    BDAVID
    Answered on August 10, 2018 at 07:14 PM

    It seems like Zapier is not able to fully read the Image Picker widget. You can try to capture the URLs in a separate field. Please try the following:

    1) Add a Form calculation widget: 

    1533942394FormCalculations.png

    2) Capture the Image field as a string, example:

    1533942778capture.gif

    So, all the links will be contained in that field, which should be passed to Zapier entirely, not just the first link.

    Hope that helps.