Why isn't the 'Create a New Form' button working?

  • Profile Image
    Asked on December 17, 2012 at 09:54 AM

    I was logged in to Firefox and creating forms a few hours ago, but now for some reason, the 'Create a form' button does not have a link connected with it.  The link is gone from the source code.

    I've tried logging in and out. I tried Chrome and Opera, still nothing.

    Finally, I tried IE and was shown the 'old style' interface with a different create a form area and was able to work around it.

    Why can't I use the orange 'Create A Form' button on these other browsers anymore? 

  • Profile Image
    Answered on December 17, 2012 at 10:02 AM

    We're sorry for the inconvenience. I was able to recreate the problem on my end so I have submitted a bug report ticket to our devs.

    You can be assured that they will have this fixed soon. Thank you very much for your patience on this matter.

  • Profile Image
    Answered on December 17, 2012 at 10:34 AM

    The problems on My Forms are now fixed. Please re-try it and if the problem continues let us know.