How to force the update?