What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    radio buttons, required field: red alert even though option is selected

    Asked by Masalamedia on December 28, 2012 at 10:50 PM

    I have a radio button field; it goes into red-alert mode (required field) as soon as I enter a value.

    I can select any of the three possible values and then click or tab to another field but the red alert remains active.

    Why?

    Page URL:
    http://form.jotform.us/form/20997458229165

    Screenshot
  • Profile Image
    JotForm Support

    Answered by liyam on December 29, 2012 at 01:36 AM

    Hello.  Can you tell us the browser version that you're using?  I tried checking on IE, Firefox, and Chrome but I could not replicate your problem.

    We'll wait for your response.

    Thanks.

  • Profile Image

    Answered by Masalamedia on December 29, 2012 at 03:00 PM

    The problem was with Mac/Firefox. Today it's not doing it.

  • Profile Image

    Answered by Masalamedia on December 29, 2012 at 03:05 PM

    No, wait, I take it back. The problem persists.

    Just emptied cache and restarted, it continues to behave this way on MacOS 10.8.2 with Firefox 17.0.1.

     

  • Profile Image
    JotForm Support

    Answered by Deygus on December 29, 2012 at 03:50 PM

    We do apologize about this and thank you for providing us with that information. I've tested it as well with the settings you provided but I couldn't replicate the problem either. 

     

    I also know that sometimes the requirement warning will appear to get stuck which usually is the result of the page timing out towards the end of the page load but it's usually minimal and doesn't show it as a detected problem. This is usually fixed with a simple refresh or it is easily also corrected by clicking in the required field again to reselect it but the chances of this happening are pretty rare but it does happen occasionally. The reason I know this is because this has happened to me in Chrome on Windows 7 and 8 a couple of times.

    Please let us know if you are still having problems with this.